Main

FLY 2000 TV - Pъководство и помощна информация

Предговор от автора на превода и българската редакция

Встъпително уточнение

Авторът на този материал няма претенции за пълна изчерпателност, както и за налагане на лични мнения и изводи по отношение на коментирания софтуер/хардуер. Целта на настоящата публикация е да бъдат подпомогнати евентуалните потребители на FLY 2000 TV, които срещат затруднения с достъпния интерфейс и настройки, в частност такива на руски език. Материалите и използвани екранни снимки (screenshots), външни препратки (hyperlinks), самостоятелни разработки (в частност Български интерфейс) и пр. се публикуват при условия „As it is“ – авторът/редакцията не носи отговорност за възможни вредоносни въздействия под влияние на софтуера и съдържанието на цитирани интернет-препратки! Същите могат да бъдат ползвани по свое осмотрение, при съответните условия за ползване и изключително за своя сметка и риск.

Съвет за спестяване на време и усилия

Препоръчително е потребителите на софтуерния пакет да се запознаят със следващите бележки – това впоследствие би могло да спести много ценно време при инсталиране на хардуер, драйвери и работа със софтуера. В ръководството се намират и отговори на ред въпроси, които са детайлно разяснени. За тези, които все още не са се ориентирали в многообразието от модели TV-тунери и (може би) най-съществения фактор – добър софтуер с поддръжка в различни операционни системи, материалът би могъл да спомогне за постигане на оптимално съотношение цена/качество в съответствие с желания краен резултат при планиране на определен бюджет за закупуване на съвременен ТV-тунер с лесен за употреба софтуер и драйвери.

Бележки по превода и редакцията. Терминологични особености. Източници на информация. Условия за ползване.

Този материал представлява разширен и редактиран превод на оригинални инструкции, интерфейс и Help-файлове на програмата, публикации в Мрежата и други материали от руски език. Използвани са източници и снимки (screen shots), публикувани на официалния сайт на FLY 2000 TV, както и някои авторски материали и коментари. Материалът се публикува за улеснение на българските потребители на FLY 2000 TV. Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията ©FLY 2000 TV; Bulgaria. При нарушения се носи отговорност съгласно Закона за авторското право и сродните му права, Европейските и международни правни норми за закрила на интелектуалната собственост.

При превода на интерфейса, помощни инструкции и др. материали, по правило са полагани усилия да се следват стриктно постройките на оригиналните текстове за избягване на смислови и/или терминологични неточности и при необходимост - предоставяне на възможности за по-лесно сравнение с основните източници.

При редакцията някои термини (най-вече свързани с менюта на програми, опции и съобщения на операционната система) са възстановени от руски на английски език (без да се превеждат на български език). Това е направено умишлено при редактирането – лично мнение на автора/редактора е, че в ХХІ век няма смисъл да се превеждат специфични термини (от сорта на „Recycle Bin” > „Кошче за отпадъци” и пр.), с които масовият потребител би трябвало да се справя свободно. Такива термини са представени в курсив (Italic) и са оцветени в цвят (font) „indigo”. в самата програма също така има някои менюта, интерфейсът на които в оригинал е в англоезичен вариант - например меню за настройки на апаратен декодер и матрица за квантоване. Това не са „недоработки” или пропуски в програмата, a e направено от разработчиците умишлено – в случая става въпрос за вид допълнителна защита срещу непрофесионални действия, доколкото подобни финни настройки изискват значително по-задълбочени познания на материята и практически опит. За болшинството потребители тези настройки са зададени с оптимални стойности по подразбиране и няма необходимост от допълнително експериментиране. Въпреки това, за професионалисти в програмата са предвидени и опции за донастройки на такива настройки. Трябва да се има предвид, че при различните версии на операционни системи някои системни екрани, падащи менюта, прозорци, команди за изпълнение и пр. имат различен интерфейс и транскрипции от описаните по-долу. Примерите и екранните снимки (screen shots) в материалите са изведени при инсталиране и тестване на драйвери и основна програма на базата на широко разпространената версия Windows XP (SP2) в англоезичен вариант.

Оригиналният рускоезичен интерфейс (менюта, подменюта, команди, съобщения, технически термини и пр.) и преводът на български език са в цвят ”teal”, като при всяка възможност са правени екранни снимки от българския интерфейс на програмите при инсталиране на софтуер FLY 2000 TV v.2.38; хардуерен модул – хибриден тунер Behold TV H6 с чипсет SAA7135 / ВЧ-модул МК3 (поради което някои screen shots за тунери с чипсет SAA7134, различни от посочения ВЧ-модул са в непроменен вид - на руски език от оригиналните материали, без български интерфейс/превод).

Някои по-специфични термини и текстове (при превода на които е възникнало съмнение за коректните термини на български език или е необходимо последващо доуточняване и/или редактиране) са оставени непреведени. Такива текстове/термини са оцветени в „orange”. При всяка следваща редакция се полагат усилия проблеми от такъв характер да бъдат окончателно уточнени и преведени (или обяснени), доколкото това е по възможностите на автора/редакцията.

Авторът на българския интерфейс на софтуерния продукт FLY 2000 TV, превода и редакцията на инструкциите и други материали, свързани с представянето на софтуер и ТВ тунери Beholder® на българския и европейския пазар с внимание и благодарност ще очаква всякакви коментари или забележки за установени евентуално допуснати неточности/грешки, както и отзиви във връзка с практическото ползване на тунерите и фирмения софтуер.

Мащина на времето...

Най-старата и все още достъпна за сваляне версия е Fly2000 Version 1.00 FREEWARE ©2002 Золотарев Андрей. Съдейки по самото име на програмата и структурата на файловете, началото е положено още през 2000 г. С оглед на горната уговорка за дистанция във времето следва да се отчита, че източникът на този материал е публикуван на официалния сайт на програмата по времето, когато масово се произвеждат ТV-тунери с чипсет BrookTree 878(A), а тунери с чипсети Philips SAA713x бавно, но убедително си пробиват път на пазара.

Някои текстове се отнасят за далечното време (за мащабите на компютърния прогрес) отпреди 5 (и повече) години. Така например, дори масово разпространените чипсети SAA713x вече не са с марката Philips, а NXP... За изминалите години са написани множество различни програми за управление на РС ТV-тунери с въпросните чипсети, отстранявани са различни недостатъци и „бъг“-ове, осъвременявани са различни драйвери за управление. Въпреки това (по наблюдения върху някои по-специализирани форуми за ТV-тунери, софтуер и драйвери за тях) FLY 2000 TV продължава да се използва до днешни дни и в някои случаи остава за предпочитане пред оригиналния софтуер, с който се предлагат някои (вкл. съвременни поколения) ТV-тунери.

С Ъ Д Ъ Р Ж А Н И Е:

Обща информация

Особености на програмата

Системни изисквания

Описание на интерфейса

Ключове за командния ред

Съвети за видеозахват

Въпроси и отговори (FAQ)


Fly 2000 TV

FLY 2000 TV (доп.р. - на базата на интерфейс за версия 2.38 Shareware)

FLY 2000 TV (б.р. по-нататък за краткост съкратено само "програма/та" или FLY 2000 TV) e програма за PC TV-тунери, построени на базата на чипсети Philips SAA7130, SAA7133, SAA7134 и SAA7135. Изградена е на базата на технология Microsoft DirectShow, което позволява да се извършва захват на двете полета на кадър 768x576, да се записват AVI-файлове с размер над 2 GB, коректна работа в Windows 2000(XP), предоставят се и много други възможности.

По време на разработването и пулбикуването на първите версии на FLY 2000 TV голяма част PC TV-тунери са построени на широко разпространения (за времето си) чипсет BrookTree 878(A), известен още като Conexant Fusion 878A. Този чипсет представлява 9-битов видеодекодер и наследява от своя предшественик Bt848 всички недостатъци, свързани с лошо качество на декодиране на стандарт СЕКАМ. За работа на ТV-тунери с такива чипсети има написани много и разнообразни софтуерни продукти.

FLY 2000 TV се разрабатва пъроначално за управление на TV-тунери на базата на чипсет-видеодекодери Philips (NXP) - серии SAA713x. Тези чипсети за разлика от Bt8x8 са 9-битови видеодекодери. Качеството на декодирано изображение при SAA713x е осезаемо по-високо, отколкото при Bt8x8. Особено добре това е видно при изображения по стандарт SECAM. При SAA713x качеството на цветопредаване се приближава до това на битовите телевизори. Недостатък при някои модели TV-тунери с чипсети Philips са не съвсем изпипани WDM-драйвери. С FLY 2000 TV се прави опит да се поправят някои недостатъци на фирмения софтуер за подобни тунери.

FLY 2000 TV може да работи в два режима:

1) Режим на управление чрез WDM-драйвер;

2) Native режим (режим на управление на чипсет SAA713x на ниво регистри).

Режимите на работа се избират от панела за настройки в секция «Устройства».

Програмата не рабти с VxD драйвери.

Първият режим поддържа практически всички тунери с WDM-драйвер. Също така, чрез дадения режим се поддържат тунери с чипсети Conexant Fusion 878 и Conexant CX2388x. Трябва да се има предвид, че в тези случаи качеството на работа на програмата в дадения режим изцяло зависи от WDM-драйвера на съответния производител. Към момента на публикуване на FLY 2000 TV много такива тунери са с недоработени WDM-драйвери, което създава проблеми на потребителите. В този режим не е достъпна поддръжка на пултове за ДУ, както и множество допълнителни настройки.

За ТВ тунери с чипсети Philips SAA713x трябва да се избира режим на работа Native.

Native режим се основава на директно програмиране на регистрите на чипсета, като се заобикаля WDM-драйвер. Въпреки това, за този режим също е необходим WDM-драйвер (по-точно kernel-mode) за обезпечаване на концепцията DirectShow. В Native режим се поддържат няколко пулта ДУ, както и множество фини настройки на чипсети SAA713х.

В Native режим трябва ръчно да се изберат конкретен модел ТВ-тунер и ВЧ-блок. В болшинството случаи ВЧ-блокът се инициализира автоматично въз основа на даните за конкретния модел ТВ-тунер. (n.a. Aко избраният модел тунер не е в списъка, WDM-драйверът може да бъде изпратен на разработчика, при което ще бъдат положени усилия същият да бъде добавен в списъка с поддържани модели. Ако е желателно да бъде добавен пулт ДУ (който липсва в списъка с поддържани пултове) това може да бъде направено, като се свали от сайта на програмата инструмент FlyTest, на базата на данните от който да бъде предоставена информация за конкретния пулт ДУ).

Внимание! Поддръжат се САМО пултове за ДУ, IR-датчикът на който се включва директно към ТВ-тунера. Всякакви други COM- и USB-датчици не се поддържат от FLY 2000 TV.

За нормална работа на Native режим е желателно да се инсталира универсален Philips reference драйвер 2.1.5.0. Това се отнася за чипове SAA7133-7135. За чип SAA7130 може да се инсталира всякакъв WDM-драйвер, но за коректна работа се препоръчва версия 2.1.0.1.

Причината е свързана с това, че болшинството WDM-драйвери имат множество вградени таймери, които постоянно възстановяват стойностите на регистрите на чипсети SAA7133-7135 в стойности по подразбиране и болшинството допълнителни настройки на програмата няма да работят. Освен това най-вероятно ще се наблюдава затихващо "съскане" на звук при чип SAA7134. Драйвер 2.1.5.0 на практика е освободен от вътрешни таймери и е достатъчно стабилен, поради което се препоръчва като оптимален.


Base features

Основни възможности на FLY 2000 TV

  • Програмата позволява гледане на ТВ-програми, излъчвани в стандартна честотна мрежа по региони, както и на канали, които се излъчват в нестандартни честоти за даден регион (в честотен диапазон 48.75 ~ 855.5 Мhz *б..р. - в зависимост от модела ВЧ-модул).

  • Позволява слушане на FM-радио в разширен диапазон 66-190 МНz *в зависимост от модела ВЧ-модул (само за модели с FM-тунер).

  • Индивидуални настройки на яркост, контраст, оттенък (само PAL), наситеност, острота (Sharpness), ниво на входен сигнал (Gain), аудиоформати (Mono, A2, NICAM), видеоформати (PAL/SECAM,NTSC), сила на звук, аудио баланс на ляв и десен канал, Zoom и Shift на изображение, позиция на кадър за всеки ТВ-канал.

  • За режими на работа Вход "Composite" и "S-Video" - запомняне на видеоформати (PAL/SECAM/NTSC), както и нива на яркост, контраст, оттенък (само PAL), наситеност, острота, видеоусилване (Gain), режим horizontal PLL.

  • Поддръжка на няколко модела пултове за ДУ и възможност за настройки на бутони от ПДУ за зададени действия.

  • Използване на «Агент» («Agent») за стартиране на програмата от пултове за ДУ.

  • Интегрирано (вградено) OSD ("On-Screen Display") меню.

  • Многоезичен интерфейс – Български, Руски, Английски (предвидена е възможност за добавяне и на други езици).

  • Възможност за изменeние на размери на кадър за извеждан видеопоток при гледане (до 768x576).

  • Поддръжка на филтър Overlay Mixer, позволяващ принудително включване на overlay в YUY2-формат.

  • Поддръжка на филтър VMR - Video Mixing Renderer (само за Windows XP).

  • Поддръжка на филтър VMR9 - Video Mixing Renderer9 (само под DirectX9).

  • Поддръжка на видеокодек Microsoft WMV9 VCM.

  • Възможност за използване на ефект SmartBob, позволяващ удвояване честотата на кадри при гледане (25->50 fps).

  • Возможност за Deinterlace (премахване на т.н. „гребеновидни” рус.„разческа” ефекти), Denoise (премахване на шум), Sharpness (увеличаване на острота / рус.„резкость”), Inverse (инверсия на цветове) при гледане.

  • Възможност за „Сърфинг“ - многоканален предварителен мозаечен преглед на канали.

  • Прихващане (Screen shot) на отделни кадри във формати BMP и JPEG както ръчно, така и по таймер с допълнители възможности за промяна/разместване (рус.„смешивание”) на полета (Deinterlace).

  • Запис на звук в WAV-формат с използване на ACM-кодеци по технологии Microsoft ACM и DirectShow.

  • Запис на видео/аудио във формат Microsoft AVI (с размер на кадър до 768x576) и компресиране в реално време с използване на инсталирани в системата кодеци и визуализиране на подробна информация за процеса на запис.

  • Възможност за подрязване (cropping) по границите на кадър при видеозахват.

  • Възможност за деинтерлейс и потискане на шум при видеозахват в AVI.

  • Компресиране на звук в реално време при захват в AVI-файл (препоръчва се формат PCM).

  • Едновременен захват и преглед на видео при размер на кадър > 288 по вертикал (с помощта на филтър Smart Tee).

  • Захват на AVI-видео в с раздробяване на файл на сегменти в зададен размер.

  • Допълнителна възможност за синхронизация на аудио- и видеопотоци.

  • Декодиране на звук от вграден аудио АЦП чипсет Philips SAA7133-7135.

  • Видеозахват в реално време в MPEG1- и MPEG2-формати (с инсталиран енкодер Honestech MPEG или Intervideo MPEG).

  • Стартиране на програмата и запис в зададено време (по таймер).

  • Таймер за изключване.

  • Поддръжка на съхраняеми пресети за AVI-, MPEG-, WAV-, STILL-захват.

  • Декодиране на кирилизиран телетекст (необходим е DirectX 8.1).

  • Поддръжка на теми (skins) в Windows XP.


System Requirements

FLY 2000 TV - Системни изисквания

Софтуерни изисквания:

  • Операционна система Windows 98SE*/ME* /2000/XP.

  • Инсталиран DirectX 8.0 или по-висока версия. Желателно - DirectX 8.1 (Задължително за работа на Телетекст).

  • Инсталирани WDM-драйвери за тунера.

  • За дънни платки с не-Intel чипсети е необходимо задължително инсталиране на пакет драйвери от производителя (например за VІА-пакет 4in1).

Хардуерни изисквания:

  • Процесор – min. Pentium II 333МНz или по-мощен (желателно). Препоръчително - Pentium IІІ (Duron, Athlon). За ползване на всички функции на видеопроцесинг е необходим процесор не по-слаб от Pentium ІII 800 МНz. За захват на пълен кадър 720х576 реда е необходим процесор не по-слаб от Athlon ХР 2000+ или Р4-2000.

  • Оперативна памет: 64МВ RAM (за видеозахват минимум 128 МВ).

  • DirectX–съвместима аудиокарта (АС 97 Sound не се препоръчва).

  • DirectDraw–съвместима видеокарта с поддръжка на Overlay.

  • Инсталиран TV-тунер с чипсет Philips SAA713x (или Bt878, CX2388x).

  • НDD-5400 об./мин. За захват са желателни 7200 об./мин. или RAID-масив.

Програмата (първоначално) е тестивана под Windows 98**, Windows ME**, Windows XP при следната конфигурация:
MB - Albatron KX400+ PRO-C (VIA KT333 + VIA8235)
CPU - AthlonXP 1700+ (up 2000+)
RAM - 256Mb PC2700
Videocard - Abit Siluro GF4MX440 (detonator 43.45)
TV Tuner - Chronos Video Shuttle II FM (SAA7130HL), LifeView FlyVideo 3000 FM (SAA7134HL)
Sound - Creative SB Live! 5.1 DD.
HDD1 - 60Gb Seagate Barracuda ATA IV (7200RPM)
HDD2 - Quantum Fireball lct20 (4500RPM)

(доп. р.) ** Забележка: От м. Юли 2006 г. официалната поддръжка на ОС Windows 98SE/ME е прекратена от страна на Microsoft®. Забележки по работата на драйвери и програми в средата на тези операционни системи не се разглеждат.


Interface

Интерфейс на програмата

Видеопрозорец

Главен панел

Панел за настройки

Панел за захват (Capture)

Модул за планирани задачи


Main Screen

FLY 2000 TV - Видеопрозорец

С десен клик на мишката се извежда контекстно меню:

  • На пълен екран / Full Screen mode – Превключване на пълноекранен режим/режим „в прозорец“.

  • Режим мини-прозорец / Simple/Extended menu – Режими за визуализиране на съкратено/пълно меню.

  • Канали / Channels - Списък за бърз достъп до настроени ТВ-канали.

  • Сърфинг на канали / Сhannel Surfing – Мозаечен сърфинг (предпреглед) на канали.

  • Съотношение на страните / Aspect Ratio - Съотношения на страните на кадър.

  • Размер на видеопрозорец / VideoWindow Size - Геометричен размер на видеопрозорец.

  • Размер на видеопоток / VideoStream Size - Размер на кадър за видеопоток (За PAL при височина на кадър <=288 се извежда едно поле, >288 се извеждат две полета. За NTSC съответно 240).

  • Като видео / As video – Привеждане на геометричния размер на видеопрозореца към размери на кадър във видеопоток.

  • Видеовход / Video Input – Превключване на входове TV, Composite, S-Video.

  • Видеостандарт / Video Standard - Избор на видеостандарт PAL/SECAM/NTSC.

  • Аудиостандарт / Audio Standard - Избор на аудиостандарт (достъпно само за чипсет SAA7134).

  • Настройки / Settings – Отваряне на прозорец за настройки.

  • Видеозахват (Capture) / Capture panel - Отваряне на панел за запис.

  • Прозорец с рамка / Window with border - Изобразяване на прозорец с рамка.

  • Върху всички прозорци / Always On Top - Програмата се разполага върху всички други прозорци.

  • Скриване на видеопрозорец / Hide VideoWindow - Скриване на видеопрозорец.

  • Свиване в tray / Suspend to tray - Привеждане на програмата в режим на очакване.

  • Изход / Exit – Изход от програмата.

С десен клик върху иконата в tray се извежда съкратено контекстно меню с основни опции и ред за за възстановяване


Main Panel

FLY 2000 TV - Главен панел

Нормален изглед (основен панел)

Разгънат (разширен)

Показване/скриване на допълнителния панел за основни настройки на изображение се извършва с натискане на бутон ▲▼

  • Reset – Възстановяване на зададени величини на видеомиксер по подразбиране.

  • VCR Mode – Блокиране на хоризонтална синхронизация. Необходимо е при включване на видеокасетофон или при гледане на местни канали в ДМВ (дециметров обхват) с нискокачествена апаратура (без включена опция за такива източници може да се получи срив на синхронизация, „придърпване” и изкривяване на изображение).

  • Десен клик с мишка по бутон "Канали" извежда контекстно меню със списък на настроени TV- или FM-канали.

  • Десен клик с мишка по име на канал извежда контекстно меню с режими за скролинг на текст.

  • Клик с мишка по часовника извежда Sleep Timer, десен клик с мишка по който извежда контекстно меню с опция за избор на време до изключване. При зададено време за изключване, с клик по часовника се извежда оставащо време до изключване.

  • Бутон "A" - бърз захват на аудио в WAV-формат.

  • Бутон "V" - бърз видеозахват.

  • Десен клик с мишка по бутон "V" извежда контекстно меню с възможност за добавяне на функция към бутон "V":

    1. Бърз захват в AVI

    2. Бърз захват в MPEG

    3. Бърз snapshot на екран

    4. Бърз multi-snapshot на екран


OptionsPanel

FLY 2000 TV - Панел за настройки

1. Секция за настройки на ТВ-канали:

· Стандарт на канал – Задаване на видео- и аудиостандарт за избрания канал. За чипсети SAA7134 е достъпен бутон за фина ръчна донастройка на подносещи при декодиране на аудио от SIF. Режим Autodetect за видеоформат работи само за чипсети Philips SAA713x.

· Автосканиране – Извикване на диалог за търсене на ТВ-канали.

· Настройка по честота – Позволява да се настрои канал с въвеждане на ТВ честота, а не по зададена по по default честотна мрежа на канали за избрания регион. В този режим избран код на регион няма значение – може да се зададе произволна честота от 45 до 990 МНz.

· Усилване - Усилване и баланс на линейния вход за избрания канал.

· Видеомиксер – Група елементи за изменение на: тип видеостандарт (PAL/SECAM/NTSC), яркост, контраст, оттенък (само за PAL/NTSC), наситеност, острота (рус.”резкость”), видеоусилване (Gain) за избран канал. Има бутон за възстановяване на всички регулатори на изображение в стойности по подразбиране и бутон, с който се присвояват настройки за целия списък с канали. Регулатор "Острота" е достъпен само за чипсети SAA713x. Регулатор "Видеоусилване (Gain)" е достъпен само за чипсети SAA713x и само в Native режим (за SAA713x) и само при изключено АРУ (AGC - Automatical Gain Control) в секция "Видео".

Десен клик с мишка по таблицата с канали извежда контекстно меню с команди "Добавяне на канал", "Премахване на канал", "Преместване нагоре", "Переместване надолу". Тези опции са достъпни и чрез бутоните в дясната част.

С отметка срещу канал се позволява показване или пропускане на канал при прелистване на канали (може да се използва като елементарна форма на т.н.“родителски контрол").

P.S. Всякакви промени на настройки трябва да бъдат съхранени с бутон "Save". Настройки се съхраняват в INI-файл (Channels.ini). Програмата извежда напомнящо съобщение за съхраняване /отхвърляне на промени.

2. Секция за настройки на FM-канали:
За достъп до менюто за FM-настройки e необходимо да се премине в режим на работа FM (ако това не е направено, програмата извежда дискретно „балонно“ съобщение с напомняне).
След преминавне в режим FM секцията става активна и са достъпни параметри за настройки.

  • Автосканиране FM - Група за автосканиране на FM-станции по зададен честотен диапазон..
  • Ниво за детекция на сигнал - Праг на чувствителност при търсене на радиостанции. Стойности - от 1 до 7. За различни модели ВЧ-блокове този параметър е различен. Колкото по-висока стойност е зададена, толкова по-малко станции ще бъдат намерени (б.р. може да помогне за отсяване на „лъжливи“ и нискокачествени сигнали при сканиране). За ВЧ-блок TCL2002MB-1F максимална стойност е 4.
  • Ръчна настройка на станция (честота) - Група за ръчно изменение на избрана станция .
  • Усилване - Усилване и баланс на линейния вход за избрана станция.
  • С отметка срещу станция се позволява прослушване или пропускане на радиостанции при прелистване на списъка.

    P.S. Всякакви промени на настройки трябва да бъдат съхранени с бутон "Save". Настройки се съхраняват в INI-файл (Channels.ini).

    3. Секция за избор и настройки на устройства:

    • Устройство за видеозахват - Позволява избор на устройство за видеозахват (ако в системата има няколко инсталирани такива). След изменения е необходимо рестартиране на програмата. В прозореца се показват всички DirectShow-устройства за дадено устройство за видеозахват. За всяко едно устройство също така могат да бъдат извикани стандартни DirectShow-диалози (само в режим "Управление на тунер чрез WDM-драйвер"). Болшинството настройки, които се извеждат чрез тези диалози се конфигурират във FLY 2000 TV чрез потребителски интерфейс.
    • Управление на ТВ-карта (тунер) чрез WDM драйвер – Включване на режим за управление чрез WDM-драйвер. В дадения режим се поддържат тунери с чипсети Conexant Fusion 878 и Conexant CX2388x. Този режим не се препоръчва за карти с чипсети SAA713x, т.к. болшинството възможности стават недостъпни. При свалена отметка програмата работи в Native режим (режим за управление на чипсет SAA713x на ниво регистри).
    • Ръчна донастройка на CrossBar от "Settings.ini" - Опция за конфигурация на crossbar чрез настройки, описани във файл Settings.ini в секция [Crossbar]. За нестандартни (основно „изкривени“) WDM-драйвери, при които в драйвера са преплетени (объркани) аудио- и видеоизточници . Само в режим на управление чрез WDM-драйвер.
    • Автодонастройка на FM честота - Позволява включване или изключване на автодонастройка при превключване на FM-честоти. Само в режим на управление чрез WDM-драйвер.
    • Инсталиран Philips SAA713x чипсет – Автоопределяне на чипсет SAA7130-SAA7135 в системата. Само в Native режим.
    • Избор на модел тунер (по производители) - Ръчен избор на модел и тип ВЧ-блок за ТВ-тунер. От правилния избор зависи коректната работа на програмата с конкретния инсталиран модел тунер. В болшинството случаи моделът ВЧ-блок се задава автоматично въз основа на съответния ТВ-тунер. Само в Native режим.
    • При натискане на бутон настройки на ВЧ модул се извиква диалогов прозорец с опции за TV- и FM- параметри.
    • Пулт ДУ - поддръжка на няколко модели пултове за ДУ. Само в Native режим. При използване на съвместим „чужд“ пулт за дистанционно управление, бутоните могат да бъдат конфигурирани по желание на потребителя, като на всеки отделен бутон се зададе съответно действие за изпълнение
    • При натискане на бутон за настройки на ВЧ модул се извиква диалогов прозорец с опции за TV- и FM- параметри.
    • Преди изход от менюто настройки на конфигурация по желание трябва да бъдат съхранени!

  • 4. Секция за видеонастройки:

    • Извеждане на видеопоток чрез - Избор на видеорендерер за извеждане на видеопоток. Рендерер VMR е достъпен само под Windows XP. Рендерер VMR9 е достъпен само под Windows XP c инсталиран DX9. За коректна работа на VMR9 е необходима апаратна поддръжка на DX9 от видеокартата. Под Windows XP се препоръчва VMR.

    • Формат на поток - Формат за представяне на изображение при гледане. Ако видеокартата поддържа овърлей, режим YUY2 е оптимален. Режим YUY2+VideoInfo2 поддържа неквадратни пиксели и позволява винаги да се държи съотношение на страните на кадър като 4x3. Чипсет Bt8x8 не поддържа този режим. Ако има проблеми с изображение или отсъствие на такова - да се опита с режим RGB24.

    • Спазване на пропорции за VMR - Опция за VMR и VMR9 рендерер, позволяваща да се включва или изключва съотношение на страните 4x3. Изключване на дадената опция позволява задаване на свободни пропорции в зависимост от размера на видеопрозореца.

    • Размер на видеопоток - Размер за формиране на кадър от WDM-драйвера при гледане. Колкото по-висока е разделителната способност, толкова по-високо е качеството на образа. Предвидени са отделни настройки на изображение за пълноекранен режим и режим „в прозорец”. Ако разделителната способност на кадър не съвпада за тези режими, при превключване между пълноекранен режим и режим „в прозорец” ще има „прищракване”. Препоръчва се величините на режим „в прозорец” и пълноекранен режим да са еднакви. С червен цвят са маркирани разрешения, които са некратни на 64 по ширина. При такива разрешения, в режим YUY2 при включен филтър за видеообработка за карти nVidia GeForce ще се получи срив на изображение. Препоръчителни режими - 768x576 за PAL/SECAM и 704x480 за NTSC.

    • Видеообработка на изображение при гледане - Допълнителни алгоритми за видеообработка, позволяващи подобряване на качеството на изображение. Ако менюто не е активно - не е инсталиран DirectShow филтър "flyvproc.ax". За повторно инсталиране да се стартира файл "instW9x.bat" или "instW2k.cmd" (респ. за Windows 9x, Windows2000/XP) от папка FLY2000TV.

    1) Smart Bob - Включване на режим за удвояване чeстотата на кадри. Позволява постигане на по-голяма плавност на видеоизображение, но увеличава натоварването на процесора двойно. Smart Bob автоматично се изключва, ако се извеждат по-малко от две полета (по хоризонтал <= 288(240) линии). В този режим има място настройка "Четно поле - първо". Тази настройка се пази отделно за YUY2 и RGB24 режими. По подразбиране е настроена за Philips SAA713x. Ако е зададена неправилно, изображението ще придърпва.

    2) Деинтерлейс - Алгоритми за премахване на „гребеновиден“ ефект ("расческа"/comb). Режим "Blended Clipping" дава по-добро качество, но увеличава натоварването на процесора до ~30-40%. Минимално натоварване на процесора се постига при "Video Bob". Оптимален ефект при - "Greedy High Movie". Deinterlace автоматично се изключва, ако се извеждат по-малко от две полета (по хоризонтал <= 288(240) линии).

    3) Острота - Ефект за допълнително увеличаване остротата на картина. Повишава натоварването на процесора с ~10%.

    4) Премахване на шум – Ефекти за премахване на високочестотен шум от изображение. Повишава натоварването на процесора с ~10-15%.

    5) Инвертиране на цвят – Опцията е полезна при гледане на канали с инвертирани цветове (при защитени канали).

    При включване на всички ефекти силно се повишава натоварването на процесора. За разрешение на поток 768x576 и включване на всички ефекти е необходим процессор не по-слаб от PIII-800. Внимание! Режими за деинтерлейсинг, за премахване на шум, за допълнителна острота са достъпни за системи с процесори, поддържащи разширен набор на команди MMX или SSE.

    • Използване на пин Capture при гледане – Използване на пин Capture за WDM-драйвер при извеждане на изображение. Помага да се получи изображение при някои "изкривени" WDM-драйвери.

    • Philips SAA713x - видео опции - Допълнителни настройки за чипсети SAA713x. Само в Native режим.

    • Vertical Sync Recovery Mode - режим за възстановяване на вертикална синхронизация. Задава се режим, при който чипсетът възстановява вертикална синхронизация след загуба на синхросигнал (например при превключване на канали). Препоръчителни настройки - "Normal Mode" и "Fast Tracking".

    • Automatic Gain Contol - Набор от опции за настройки на видео АРУ.

    1) Use Automatic Gain Control (AGC) – включване на видео АРУ. При силни изменения на нивото на входния видеосигнал (например при кабелна ТВ) в този режим са възможни скокообразни изменения на яркост. Ако AGC е изключен, за всеки ТВ канал може ръчно да се настрои ниво на усилване от -3dB до +3dB (в секция ТВ канали).

    2) Use White Peak Control - Режим на работа на видео АРУ, при който в случай на превишение на яркостната съставляваща на видеосигнала от номиналната стойност (0 dB) сработва АРУ и се намалява яркост.

    3) Use Color Peak Control - Режим на работа на видео АРУ, при който в случай на превишение на нивото на композитния видеосигнала от номиналната стойност на АЦП сработва АРУ и нивото на сигнала се понижава.

    4) Long pause AGC at detect gain leve l - Дълга или кратка пауза преди сработване на АРУ. Дълга пауза се препоръчва ако видеосигналът е защитен Macrovision.

    • Macrovision Copy Protection Status - Показва статуса на видеосигнал - нормален или със защита Macrovision.

    • Пълен екран - Действие при переход в пълноекранен режим. Някои видеокарти не поддържат овърлей при високи разрешения. От такова положение може да се излезе, като се зададе разрешение например 800x600, в което desktop-а да преминава при превключване в пълноекранен режим. Също така може да се зададе refresh в Нz (само под Win2K / XP).

    5. Секция за аудионастройки:

    • Устройство за аудиозахват - Избор на устройство за аудиозахват (ако в системата са инсталирани няколко устройства). Някои устройства, например гласови модеми добавят в категорията устройства за аудиозахват свои устройства. За избягване на проблеми с видео- и аудиозахват, винаги трябва да се избира в списъка правилната аудиокарта. Никога да не се избира устройство "LifeView FlyVideo Audio(Video) Capture" ако такова присъства в списъка.

    • Аудиомиксер - Избор на системен аудиомиксер (ако в системата има инсталирани няколко устройства). Трябва да се избира само аудиокарта, към която е включен аудиокабелът от тунера. Някои аудиокарти (например Realtek HD Audio) имат 2 миксера - един за запис и друг за възпроизвеждане. Трябва да се избере миксер за възпроизвеждане (Output). При смяна на миксера се сменят достъпните линии за възпроизвеждане.

    • Запазване на ниво на звук при изход - Ако опцията е изключена, при изход от програмата силата на миксера се възстановява до ниво преди пускане на програмата.

    • Регулиране на Line-In вместо линия Main – Използване само на линеен (или алтернативен - избран в настройката) вход за регулиране на звук вместо от общия регулатор.

    • Изключване на избрана линия при изход – Изключване на линеен (или алтернативен) вход на миксера при изход от програмата. Позволява да се избегнат настройки в линията при неактивен тунер.

    • Стъпка за усилване - Величина в проценти за дискретно регулиране на сила.

    • Mute Delay (ms) – Закъснение по време в мс. след команда Mute. Актуално за аудиокарти от серии Creative SB Live!/Audigy, поради плавно включване/изключване на линии в тези карти. За такива карти оптимално време за закъснение е 100-140 мс. При по-малки стойности ще се чува прищракване при превключване на канали. За други аудиокарти са достатъчни 20-30 мс.

    • Източник за гледане (възпроизвеждане) - Позволява да се избира линия за регулиране на ниво на звук. Трябва да се избира линеен вход.

    • Източник за запис - Позволява да се избира линия за регулиране на ниво на запис. Трябва да се избира линеен вход.

    • Philips SAA713x - аудио опции - Допълнителни настройки за чипсети SAA713x. Само в Native режим.

    • Audio FM Dematrix - Режим Dematrixing при декодиране на ТВ-звук Dual FM(A2). Само за SAA7134 и само в Native режим. Препоръчителна настройка - Auto Switching.

    • Filter bandwidth - Ширина на пропускателна лента на филтъра при декодиране на ТВ-аудио за подносеща 1 и подносеща 2. Само за SAA7134 и само в Native режим. Препоръчителна настройка - Narrow/Narrow.

    • Auto Volume Leveling – Режими на АРУ за аудиосигнал. Само за SAA7133-7135.

    • Volume from SIF – Ниво на аудиосигнал при декодиране от източник SIF (МЧ на тюнера). Само за SAA7134 и само в Native режим.

    • Audio Input Voltage - Чувствителност на вход за различни режими. Ако силата на звук е недостатъчна, трябва да се зададе 1Vrms.

    • Аналогов ТВ-вход за SAA7134 - Опция, която позволява да се взима звук от изхода на аналоговата линия на ВЧ-блока, вместо от източник SIF. Само за SAA7134 и само в Native режим. Този режим емулира режим на работа на чипсет SAA7130. В този режим чипсет SAA7134 не се занимава с демодулация и декодиране на звук - той се взима такъв, какъвто излиза от ВЧ-блока (само Моно).

    • Philips SAA7133/34/35 - вграден АЦП – Сваляне на цифров аудиосигнал от чипсет SAA713x по PCI-шина и извеждане чрез ЦАП на аудиокартата при гледане. В този режим не е необходим кабел за свързване на аудиокартата с ТВ-тунера. Този режим не се препоръчва за използване, т.к. опорните кварцеви резонатори на аудиокартата и ТВ-тунера се различават по калибровка (т.е АЦП на тунера и ЦАП на аудиокартата ще бъдат леко разсинхронизирани) в болшинството случаи може да произтича изпреварване или закъснение на звук от видео при гледане.

    P.S. Ако в системата има няколко устройства за аудиозахват, от «Control Panel» > «Multimedia (Sound and Audio Devices)» > «Audio» в списъци «Default device» както за запис, така и за възпроизвеждане да се избере правилната звукова карта.

    6. Секция за настройки на интерфейс:

    • Избор на език - Избор на език за интерфейс. Ресурсни файлове за поддръжка на езици се намират в папка \LangRes. За инсталиране на Български език в папката трябва да бъде копиран ресурсният файл Bulgarian.f2l (б.р. вж. секция “F.A.Q.”).

    • Съхраняване сила на звук за всеки канал - При превключване на канали силата на линия миксер за всеки ТВ-канал ще бъде възстанавена до величина, настроена в секция "ТV канали", за FM - "FM канали". В противен случай величината за сила на звук ще бъде обща за всички канали.

    • Съхраняване ниво на видеомиксер за всеки канал - При превключване на канали настройките на видеомиксера ще бъдат присвоявани за всеки канал съгласно съответните настройки. В противен случай настройките на видеомиксера ще бъдат общи за всички канали.

    • Съхраняване на Zoom и Shift за всеки канал - При превключване на канали величините Zoom и Shift, настроени за изображение във видеопрозореца ще бъдат съхранени за всеки ТВ канала. В противен случай настройките на Zoom и Shift ще бъдат общи за всички канали.

    • Изключване на screen saver при активeн видеопрозорец – Изключване на screen saver и power safe на монитора в режими TV, CVBS (Composite), S-Video при активен видеопрозорец.

    • Показване на рамка около видеопрозореца – Показване на видеопрозорец с рамка.

    • Блокиране извеждане на видеопрозорец извън екрана - Ограничава позицията на видеопрозореца в границите на екрана.

    • Показване бутон на приложението в панела за задачи – Показване на бутона на приложението в панела за задачи. Опцията разрешава и превключване с Alt+Tab.

    • Зареждане в tray при старт на Windows - Автоматичено зареждане FLY 2000 TV при старт на Windows и свиване в tray (режим на очакване).

    • Бутон "Close" на главния панел за свиване в tray - При натискане на бутон "[x]" (затваряне) на главния панел се изпълнява команда „Suspend to tray” (режим на очакване).

    • Изключване на ПДУ при видеозахват - Автоматично изтключване на пулта за ДУ при видеозахват (за избягване пропускане на кадри при слаби системи).

    • Блокиране смяна на канали в режим на запис – Опцията забранява превключване на канали ако е активен процес на видео- или аудиозапис.

    • Изключване на компютъра при изход от програмата - Автоматично изключване на компютъра при изход от програмата. Ако опцията е включена, при изход от програмата 15 секунди предварително таймерът издава съобщение с предупреждение за предстоящо изключване на компютъра. На този етап може да се откаже изключването или да се премахне опцията за изключване при изход.

    • Приоритет на програмата при гледане - Приоритет на основния процес при гледане (не влияе на приоритета при запис).

    • Режим за превключване на канали - Режими за превключване на канали - единичен (1-9), двоен (1-99), троен (1-999).

    • Режим сърфинг, клетки - Количество на клетки в мозайката при сърфинг на канали.

    • Интервал на сърфинг (s) - Време в секунди, отделено за преглед на всяка клетка.

    • Задръжка на избрана клетка (s) - Време в секунди, отделено за повторно показване на изображение в клетката, в която е кликнато с мишката. Стойност „0” е ръчен режим, сърфинг няма да продължава докато не се кликне повторно по дадената клетка.

    • Започване на сърфинг от първия канал - При старт на сърфинг да се започва от първия канал от списъка.

    • Показване на всеки канал в своя клетка - При сърфинг всеки канал ще се изобразява точно в своята клетка. В този режим е желателно да бъде осигурено количество клетки не по-малко от броя на каналите.

    • Използване на външна програма за телетекст - За съжаление под Windows XP SP1, както и с инсталеран DirectX 9, Microsoft WST-декодер (използван във FLY 2000 TV) предизвиква нестабилност и крах на системата. Може да се използва например телетекст, който е в софтуера на TV-тунера "Philips teletext". В дистрибутива на FLY 2000 TV за него има адаптиран шрифт с поддръжка на Руски език (кирилица). При инсталация на FLY 2000 TV се из бира опция "Руски шрифт за телетекст". Инсталаторът ще подмени файл Smtvtxt.fon c поддръжка на руски езика в папка Windows\Fonts.

    • Зареждане на Аgent при старт на Windows - Включване или изключване възможност за автоматичено зареждане на Агент при стартиране на Windows. (вж. описание на Agent-а). Агент очаква натискане на бутон "Power" от пулта за ДУ за пускане на FLY 2000 TV с ключ от командния ред, указан от потребителя.

    7. Секция за настройки на LCD и OSD:

    • Използване на фон за OSD – Извеждане на OSD-текст на фон. Ако фон е изключен, за коректно изобразяване на прозрачен фон е необходим овърлеен режим.

    • Файл за поддръжка на език за LCD - За правилно изобразяване на шрифт на LCD-дисплея е необходима поддръжка на езици, различни от Английски. За това е необходим файл с шрифт със специален формат. Могат да се използват препратки в интернет за сваляне на шрифтов редактор. Така конструиран файл с шрифт се копира в папка \LCDFonts и се избира от списъка. С програмата се предоставя шрифт за поддръжка на руски език (кирилица/съвместим с български език).


Sheduler

FLY 2000 TV - Модул за планирани задачи

Ингегрираният Модул за планирани задачи (рус.“планировщик“) е предназначен за пускане на задания при стартирана програма. Ако програмата е била стартирана с ключ в командния ред -r: (запис), задания от модула няма да могат да бъдат изпълнявани.

По подразбиране в модула няма заредени задачи. За активиране на достъпни настройки трябва да бъде въведено задание.

  • Време на стартиране – Задаване на дата и време за изпълнение на задание.

  • Ежедневно – Изпълняване на съответно задание ежедневно.

  • Ежеседмично - Изпълняване на съответно задание ежеседмично.

  • Избор на пресет - Избор и използване на пресет преди пускане на задание.

  • Задаване име на файл - Задаване име на файл при захват (без разширение). Ако не е зададено нищо, име ще бъде формирано от timestamp.

  • Време на завършване - Време за спиране на запис. Автоматично се пресмята продължителност на време за захват.


CommandKey

FLY 2000 TV - Ключове за командния ред

Могат да бъдат използвани Windows Scheduler или друга програма за планиране на задачи за пускане на програмата в зададено време, като параметрите се управляват от командния ред. Допустими префикси за ключове са "-" и "/"

Ключ | Команда
-m:tv | Включване на режим TV
-m:fm | Включване на режим FM (за модели с FM Radio)
-m:cp | Включване на режим Composite In
-m:sv | Включване на режим S-Video In
-fs | Превключване в пълноекранен режим
-ch:xxx | Превключване на xxx канал (номерация от 1)
-mute | Изключване на общия звук (не влияе на запис на звук)
-lnmute | Изключване на звука на линейния вход на миксера
-vol:xxx | Задаване на усилване xxx (0-255)
-tr | Пускане на програмата свита в трея (suspend to tray)
-wu | Активиране на програмата от трея (wake up)
-r:avi | Начало на запис в AVI файл
-r:mpg | Начало на запис в MPEG файл
-r:wav | Начало на запис в WAV файл
-r:stillx | Начало на запис на скрийншоти с интервал x секунди
-d:xxx | Продължителност на запис xxx минути
-fn:"file" | Задаване на име на файл при запис. Ако не е зададено име се използва времева отметка (рус.“таймштамп”) (задължително в кавички)
-ps:"preset" | Посочване на име на пресет за изчитане на настройки (задължително в кавички)
-exit | След завършване на запис - излизане от програмата
-shut | След завършване на запис - излизане от програмата и изключване на РС

Пример. Да се пусне програмата, да се избере 8-ми канал, да се включи видеозапис за 25 минути във файл "tom and jerry.avi" и след края на записа да се изключи компютъра: c:\fly2000\fly2000tv.exe -m:tv -ch:8 -r:mpg -fn:"tom and jerry" -d:25 -shut
Забележка: Изход от програмата(-exit) се извършва 3 секунди след спиране на запис, изключване(-shut) - след 10 секунди.


Advice

FLY 2000 TV - Съвети при видеозахват (Capture)

За кодеците...

Болшинството AVI-видеокодеци в състава на пакет Microsoft DirectX Media са предназначени за постобработка на готово видео и са слабопригодни за работа в режим на компресиране в реално време. Болшинството от тези кодеци не поддържат YUY2 и RGB24 видеоформати.

Широко разпространеният кодек DivX също не е подхдящ за компресиране на ефирно видео в реално време. За неговото използване е желателна предварителна обработка на видеоматериала за премахване на шум. Високочестотен шум много трудно се компресира от този кодек и общото качество на изображението след компресиране при фиксиран битрейт е неудовлетворително.

DivX и Microsoft DirectX кодеци могат да бъдат използвани за окончателно видеокомпресиране с помощта на програми като Virtual Dub.

Ако целта е да се получи видео с високо качество, запис трябва да се прави или без компресиране, или с малък коефициент на компресия за намаляване на потока данни. Най-подходящ е lossless кодек Huffyuv 2.2.0, който е базиран на алгоритъма на Хафман, компресира без загуби и осигурява идеално качество на изображението. Кодек Huffyuv компресира с коефициент само 2~3, в следствие на което се формира поток от данни с обем 10~15 МВ/сек. Т.к. не всеки HDD може да записва подобен обем информация без пропускане на кадри, за компресиране без загуби се препоръчва използване на дискове с честота на въртене не по-малка от 7200 RPM или с IDE RAID масив.

Ако HDD не позволява да се записва поток с висока скорост, може да се опита да се използват Motion JPEG кодеци - Morgan MJPEG, PICVideo MJPEG, или MainConcept MJPEG. С тези кодеци може да се получи високо качество на изображение при сравнително нисък поток от данни (3~8 МВ/с). В настройките на PICVideo MJPEG кодек това съответства на качество 17~19. За Morgan MJPEG кодек – 85~95. Трябва да се има предвид, че тези кодеци компресират със загуби, т.к. са базирани на алгоритъм за вътрешнокадрова компресия JPEG.

Към кодеците, които осигуряват максимална компресия с максимално качество спада XviD. Недостатък при него е, че изисква огромни изчислителни ресурси, но качеството на изображението е високо.

По възможност трябва да се избягва да се записва в AVI с компресиране на аудио в реално време. Съществува опасност за разсинхронизация на видео- и аудиопотоците, а при използване на някои аудиокодеци това може да предизвика внезапно спиране на записа. Препоръчва се да се използва апаратен аудиоформат - PCM.

За видео и аудио...

При запис на видео съвместно със звук има ред особености. Съществуват няколко момента, за които трябва да се помни. При запис на видео и аудиоред с ТВ тунери по правило винаги участват две независими устройства - устройство за цифровизиране на видео (самата платка ТВ тунер) и устройство за цифровизиране на звук (звукова карта на компютъра). Тези устройства работят на опорна честота на своите собствени кварцови генератори, всеки от които може да има известни отклонения. Вследствие на това, при цифровизиране на данните произтича разсинхронизация по време на видео- и аудиопотоците, което в резултат води до забавяне или избързване на звук спрямо изображени е в записания файл.

Предимство на чипсети NXP (Philips) SAA7134 и SAA7135 е, че освен видеодекодер имат вграден и независим от аудиокартата на компютъра аудиодекодер. FLY 2000 TV позволява захват на аудиопоток от вградения аудиодекодер, с което се позволява постигане на синхрон на аудио- и видеоред. Тези чипсети също така поддържат режим на апаратна блокировка на аудио- към видеоред, което позволява постигане на абсолютен синхрон на потоците. Съвместен видео- и аудиозахват е възможен дори без наличие на аудиокарта. Ако тунерът е базиран на чипсет SAA7134 или SAA7135 се препоръчва винаги да се ползва тази уникална въ зможност. Важно е да се знае, че аудиодекодерът на чипсети SAA7133-7135 цифровизира звук само с честота на дискретизация 32 kHz. Аудиодекодерът на чипсет SAA7135 може да цифровизира звук с честоти до 48 kHz (както и с 44.1 kHz), но само за източник, включен към аналоговия вход на чипсета. За съжаление WDM-драйверът е блокиран за РСМ 32000 Нz, 16 bit, Stereo.

За Windows...

Благодарение на по-добрия механизъм на кеширане, буферизация и по-грамотното управление на приоритети, запис и работа с видео може да се извършва на компютри с инсталирани операционни системи Windows XP (2000), дори под Windows98 (ME).

Важно! Файлова система NTFS поддържа файлове с размер над 4 GB под Windows XP (2000) и може да се осъществява продължителен пълноформатен видеозапис със слабо компресиране. Файлова система FAT32, с която работят операционните системи Windows98 (ME) не поддържа файлове с големина над 4 GB.

В някои случаи обаче се оказва, че под Windows98(ME) картината от тунера е по-добра – с по-малко шумове и ленти при по-малко настройки. Проблемът се състои в поддръжката на програмно охлаждане на процесори в Win2000 и WinXP. Процесорите непрекъснато се привеждат в Idle режим с ниско потребление на тока и обратно, при нарастване на консумирания ток. Произтичат импулсни скокове по захранване 5V, които силно влияят на изображение и звук, особено на ДМВ-канали.

* Забележка: От м. Юли 2006 г. официалната поддръжка на ОС Windows 98SE/ME е прекртена от страна на Microsoft®. Забележки по работата на драйвера и програмния продукт в средата на тези операционни системи не се разглеждат.

При смущения...

На сайта http://tuner.ixbt.com е поместена статия за отстраняване на смущения при тунери, които възникват по линия на захранването. Автор на статията е Fizick. Дава се съвет за се запои допълнителен кондензатор с голям капацитет (2200-4700 Мкф) към шината за захранване на HF-модула на тунера. За тунери с дизайн LifeView такъв кондензатор може да се запои паралелно на кондензатора, който е маркиран на фигурата (като се съблюдава полярност!). Такава процедура позволява до 99% да се решат проблеми със смущения, свързани със захранване. Трябва да се има предвид обаче, че такива действия са за своя отговорност и риск - при неумели действия отпада гаранцията. Такава процедура е тествана и резултатите са впечатляващи. По-подробна информация е публикувана на страница http://tuner.ixbt.com/info/info_tunerout5.html.

LifeView FlyVideo 2000/3000:


Faq

FLY 2000 TV - Въпроси и отговори (FAQ)

Въпрос: При пускане на програмата има звук, но няма изображение (черен прозорец)?

Отговор: Видеокартата (драйверът) не поддържа overlay в зададената разделителна способност и битност на desktop-а. Да се направи опит да се зададе 16-битов Windows-desktop. Ако и това не помага, да се опита с изменение на формат при гледане в настройките на програмата (YUY2, RGB24), да се включи/изключи Overlay Mixer, както и да се промени размера на видеопотока. Най-добре е да се използва YUY2. При избор на овърлейна повърхост под Windows XP да се опита с включване/изключване на режим Video Mixing Renderer (VMR). Възможна е още една причина за «черен екран». При някоио дънни платки в BIOS по подразбиране е зададена неправилна стойност на PCI Bus Latency. При промяна на тази стойност може да се постигне нормална работа на PCI видеодекодер SAA713x. Препоръчителна стойност за PCI Latency е 16~64. Освен това, сървърните версии на операционните системи (Win2000 Server, Win2003 Server) по подразбиране напълно или частично изключват апаратно ускорение на видеоадаптера с цел оптимизиране на производителност. Това също води до «черен екран» или до изкривяване на цветопредаване при работа в различни режими на видеоизображение. От меню «Диагностика» («Troubleshooting») в допълнителните настройки на видеокартата да се зададе апаратно ускорение на максимум.

Въпрос: При ТВ тунер с чипсет Fusion 878A програмата „не вижда“ FM, докато с оригиналния софтуер FM работи?

Отговор: WDM-драйверът на тунера е "кастриран" и не поддържа режим FM. Оригиналният софтуер работи с FM обикновено през регистри или с допълнителни библиотеки. Да се инсталира универсален WDM драйвер от Иван Усков или Eduardo Jose Tagle.

Въпрос: Изображението е обърнато „надолу с главата“ :(

Отговор: С голяма доза вероятност може да се твърди, че е инсталиран софтуер от LifeView, който „тихомълком“ подменя в списъка с DirectShow-филтри стария филтър YUVxfm.dll с високи стойности Merit, което му дава възможност автоматично да се включва в DirectShow конвейер. Този филтър преобръща изображението в YUY2. В дистрибутива на FLY 2000 TV е включен пакетен файл "Del_xfm.bat" за премахване на филтър YUVxfm.dll от системата.

Въпрос: Запис в AVI със звук. Записът протича без грешки, но при възпроизвеждане на видеофайл няма звук?

Отговор: Причините могат да бъдат няколко:

1) Да се провери дали в настройките за аудиозапис за миксер и активна линия за запис е избран и включен точно този канал на аудиокартата, към който е включен аудиоизхода на тунера. Да се провери дали източникът не е изключен (Mute). Да се провери чрез системния миксер (sndvol32.exe -r) дали не е изключена линията;

2) Ако е избрана правилно активна линия за запис и същата е включена, но отново няма звук е възможно драйверите на аудиокартата некоректно да поддържат превключване на звукови източници през WDM. Така например, драйвери за карта Creative SB PCI 128 под Win2000 (XP), инсталирани от самия Windows работят коректно. В същото време драйвери, инсталирани от сайта на Creative под Win2000 (XP) не позволяват превключване на източник за запис дори през системния миксер.

Въпрос: При включване в режим «Телетекст» вместо шрифт се вижда псевдографика („завъртулки“).

Отговор: Това е грешка при регистрация на шрифтове в инсталатора DX8. В папка \Misc се намира файл wst_w9x.reg (за Windows 98~ME) и wst_w2k.reg (за Windows 2000). Трябва да се стартира съответният файл и да се рестартира Windows.

Въпрос: Не може да се записва видео със звук. При опит за запис се показва съобщение за грешка "Cannot start graph". Видео без звук се записва без проблеми?

Отговор: Някои устройства (например гласови модеми) добавят свои устройства за аудиозапис. От «Control Panel» > «Multimedia (Sound and Audio Devices)» > «Audio» в списъците «Default device» както за запис, така и за възпроизвеждане да се избере правилната звукова карта. Включва се отметка «Use only default devices». Рестартира се Windows. Отваря се панела за запис на FLY 2000 TV и в секция «Настройки» от списъка се избира правилна звукова карта.

Въпрос: При запис във формат AVI звукът осезаемо закъснява спрямо видеото?

Отговор: Разсинхронизация на аудио- и видеопотоците при запис може да се получи в резултат на множество причини. Опитайте да зададете формат PCM за звука. Някои аудиокарти, като Sound Blaster Live!/Audigy осигурявт синхрон само при честота на дискретизация 48000 Hz. Да се подберат видеокодек и съответни параметри така, че натоварването на процесора да не е повече от 80%. Също така не се препоръчва в настройките да се задава най-висок приоритет. Да се пробват различни стойности на параметрите «Поредност „чередование“ (Interleaving)», «Главен поток AVI». Ако това не помага, да се включи опция за автоматично ресемплиране на звук "Auto adjust audio speed for match video".Ако тунерът е с чипсет Philips SAA 7134/7135, при запис да се използва вграденият аудио АЦП.

Въпрос: При опит за видеозапис в AVI или MPEG системата "зависва"?

Отговор: Възможни са няколко типа проблеми:

1) Системни - За дънната платка не е инсталиран пакет драйвери от производителя, или в системата няколко устройства (напр. тунер и звукова карта) делят едно и също IRQ-прекъсване;

2) Програмни - конфликт на драйвери или DirectShow-филтри. Още един съвет - в пълния пакет драйвери LifeView FlyVideo 2000/3000 вхлиза стар филтър YUVxfm.dll, който дава отвратително качество на преобразуване YUV->RGB и понякога става причина за зависване при опит за захват. Този филтър понякога може също така да дава преобърнато изображение. В комплекта DirectX 8 е включен по-качествен филтър AVI Decompressor, поради което необходимост от YUVxfm.dll отпада. В дистрибутива на FLY 2000 TV се намира пакетен файл "Del_xfm.bat" за премахване на филтър YUVxfm.dll от системата.


License

Лицензионни условия

FLY 2000 TV се разпространява при условия "shareware" с 30-дневен пробен период.

· Всички авторски права върху FLY 2000 TV принадлежат на автора - Золотарёв Андрей.

· Потребителите имат право да използат програмата в течение на 30-дневен изпитателен период. След завършване на този период престават да бъдат достъпни болшинството функции. Ако не се предвижда FLY 2000 TV да бъде използвана впоследствие, програмата трябва да бъде деинсталирана. За по-нататъшно използване е необходима регистрация и получаване на регистрационен ключ.

· На регистрирани потребители се предоставя право за използане на FLY 2000 TV едновременно само на един компютър.

· Регистрирани потребители имат право безплатно да получават всички следващи версии на програмата.

· Нерегистрирани версии на FLY 2000 TV могат да бъдат разпространявани свободно при условие, че оригиналът на дистрибутива не се променя. Забранено е да се внасят изменения в кода на програмата. Забранена е продажба на програмата и разпространение с търговски цели без писмено разрешение от автора.

· Авторът не носи отговорност за възможни последствия от използването на програмата, включително възможни повреди на оборудоване и/или операционната система. Авторът не носи отговорност при загуба или промяна на данни в резултат на използване или на неправилно използване на този софтуерен пакет.

· Инсталиране и използване на FLY 2000 TV предполага, че са приети положенията в настоящите лицензионни условия и се декларира съгласие със същите.

· При несъгласие с лицензионните условия, файловете на FLY 2000 TV трябва да бъдат премахнати и да бъде прекратено използването на програмата.

* доп.р. Материалите по темата на Български език, използвани екранни снимки (screenshots), външни препратки (hyperlinks), самостоятелни разработки (интерфейс) и пр. се публикуват при условия „As it is“ - авторът на същите не носи отговорност за възможни вредоносни въздействия под влияние на програмите, съдържанието на публикуваните интернет-препратки и др. връзки! Същите могат да бъдат ползвани по лично осмотрение на потребителите, при съответните условия за ползване и изключително за своя сметка и риск.


Registration

Регистрация

Регистрация на програмата FLY 2000 TV за граждани на Русия струва 190 руб., в които не са включени банкови разходи за превод на средствата.
Образец и банкови реквизити са посочени тук .

Регистрация на програмата FLY 2000 TV за граждани на СНГ (бивш СССР) струва 6 € (Евро), в които не са включени банкови разходи за превод на средствата.
Образец и валутни банкови реквизити са посочени тук . Преводът трябва да бъде в Евро.

След заплащане да се изпрати уведомително писмо по e-mail на адрес auzol@inbox.ru . В поле "копие" трябва да бъде посочен адрес zolotar@kz.abakannet.ru . В писмото трябва да бъде посочено име, на което да бъде регистрирана програмата (дължината на името трябва да бъде не по-малка от 10 и не по-голяма от 30 символа, желателно на английски, може и с интервали). В отговор ще бъде изпратен ключ. По възможност да се сканира платежния документ (във формат jpg, не по-голям от 80 КВ) и да се приложи към писмото, при което ключ ще бъде изпратен незабавно. В останалите случаи ключ се изпраща след получаване на плащането (около 3-6 дни).

Други начини за заплащане на регистрация:

1) WebMoney ( http://www.webmoney.ru )
2) Яндекс.Деньги (на базата на PayCash) ( http://money.yandex.ru )

Стойността на регистрация чрез система WebMoney за граждани на Руссия и СНГ е 210 WM в еквивалент RUR (Руски рубли) или 7 WM в еквивалент USD. Реквизити за плащане по система WebMoney са посочени тук

Стойността на регистрация чрез система Яндекс.Деньги за граждани на Руссия и СНГ е 210 рубли. Реквизити за плащане по система Яндекс.Деньги са посочени тук

След перевод по WebMoney или Яндекс.Деньги, да се изпрати уведомително писмо по e-mail на адрес auzol@inbox.ru . В поле "копие" да се посочи адрес zolotar@kz.abakannet.ru . В писмото трябва да бъде посочено име, на което да бъде регистрирана програмата (името трябва да бъде на английски, може и с интервали). С писмо-отговор ще бъде изпратен ключ.


Contact

Информация за контакти

Автор на програмата, програмиране, дизайн - Золотарёв Андрей.

Дизайн на главния панел - Виктор Рюхин aka VJ Ryu-Hin.

E-mail: auzol@inbox.ru

Адрес в Интернет: http://www.fly2000.ru

Благодарности на:

Сергей Андык
E-mail: asvzzz@asvzzz.com
Адрес в Интернет: http://www.asvzzz.com

Дмитрий Корнев
E-mail: tvman@yandex.ru
Адрес в Интернет: http://tuner.ixbt.com

Виктор Рюхин
E-mail: Ryu-Hin@yandex.ru

Автор на Български интерфейс ©2010, превод и редакция на Help (вкл.СНМ) / Инструкции за инсталиране и работа с програмата, други материали по темата:

E-mail: thebest@mail.bg

On-line (Athorisation requirement) -

Skype: simply_thebest

QIP (ICQ): thebest (116449009)


Предговор от автора на превода и българската редакция

Препоръчително е потребителите на програмата FLY 2000 да се запознаят със следните уводни бележки – това впоследствие ще спести много ценно време при инсталирането на хардуер, драйвери и работа със софтуера и ще отговори на ред въпроси, които са детайлно разяснени в ръководството. За тези, които все още не са се ориентирали в многообразието от различни модели и марки ТV-тунери1 и (може би) най-съществения фактор – перфектен софтуер с безупречна работа и поддръжка в различни операционни системи, се предоставя справочна информация за постигане на оптимално съотношение цена/качество в съответствие с желания краен резултат при планиране на определен бюджет за закупуване на най-съвременен ТВ тунер и софтуер за управление.

Този материал представлява превод и редакция на оригиналните инструкции и други материали от руски език. Използвани са материали и снимки (screen shots), публикувани на официалния сайт на Fly 2000 TV, както и някои авторски материали и коментари.

При превода на интерфейса, помощните инструкции и др. материали, по правило са положени усилия да се следват стриктно постройките на оригиналните текстове за избягване на смислови и/или терминологични неточности и при необходимост - предоставяне на възможности за по-лесно сравнение с оригиналните материали.

При превода и редакцията някои термини (най-вече свързани с менюта ня програми, опции и съобщения на операционната система) са възстановени от руски на английски език, без да се превеждат на български. Това е направено умишлено при редактирането – лично мнение на автора/редактора е, че в ХХІ век няма смисъл да се превеждат специфични термини (от сорта на „Recycle Bin” > „Кошче за отпадъци” и пр.), с които масовия потребител би трябвало да борави свободно. Такива термини са представени в курсив (Italic) и са оцветени в цвят (Font) „indigo”. в самата програма също така има някои менюта, на които оригиналният интерфейс е в англоезичен вариант - например менюто за настройки на апаратния декодер и матрицата за квантоване. Това е направено от разработчиците умишлено, а не са „недоработки” или пропуски в програмата – в случая става въпрос за вид допълнителна защита срещу непрофесионални действия, доколкото подобни финни настройки изискват значително по-задълбочени познания на материята и практически опит. За болшинството потребители тези настройки са зададени с оптимални стойности по подразбиране и няма необходимост от допълнително експериментиране. Въпреки това, в програмата са предвидени и такива настройки - за професионалисти. Трябва да се има предвид, че при различните версии на операционните системи някои системни екрани, падащи менюта, прозорци, команди за изпълнение и пр. имат различен интерфейс и транскрипции от описаните по-долу. Примерите и екранните снимки (screen shots) в материалите са приведени при инсталиране и тестване на драйвер, основна програма и плъгини на базата на широко разпространената версия Windows XP (SP2) в англоезичен вариант.

Оригиналният рускоезичен интерфейс (менюта, подменюта, команди, съобщения, технически термини и пр.) и преводът на български език са в цвят ”Т eal”, като при всяка възможност са правени екранни снимки от българския интерфейс на програмите при инсталиране на драйвери и софтуер FLY 2000 ТV v.2.38; хардуерен модул – хибриден тунер H6 с чипсет SAA 7135 / ВЧ-модул МК3 (поради което някои screen shots за тунери с чипсет SAA 7134, ВЧ-модули Xceive XC5000 са в непроменен вид - на руски език от оригиналните материали, без български интерфейс/превод).

Някои по-специфични термини и текстове (при превода на които е възникнало съмнение за коректните термини на български език или е необходимо последващо доуточняване и/или редактиране) са оставени непреведени. Такива текстове/термини са оцветени в „orange”. При всяка следваща редакция се полагат усилия проблеми от такъв характер да бъдат окончателно уточнени и преведени (или обяснени), доколкото това е по възможностите на автора/редакцията.

Този материал се публикува за улеснение на българските потребители на софтуер FLY 2000 ТV. Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията © FLY 2000 TV ; Bulgaria. За нарушения се носи отговорност съгласно Закона за авторското право и сродните му права и международните правни норми за закрила на интелектуалната собственост.

Авторът на българския интерфейс на софтуерния продукт FLY 2000 T V, превода и редакцията на инструкциите и други материали, свързани с представянето на ТВ тунери Beholder® на българския и европейския пазар с внимание и благодарност ще очаква всякакви коментари или забележки за установени евентуално допуснати неточности/грешки, както и отзиви във връзка с практическото ползване на тунерите и фирмения софтуер.