Application: List TV

List TV
Помощна информация на български език
Next page >
List TV
User guide

Created with DrExplain

Next page >
Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията!
© ListTV; Beholder-Europe.com


Application: List TV

List TV
< Previous page Next page >

List TV

Помощна информация на [image] език

Кратко сравнително

Оригинална постройка | Българска версия

The contents of List TV

Въведение
Основни възможности
Настройки
Допълнителна информация
Обновяване и обратна връзка
Българска редакция

Created with DrExplain

< Previous page Next page >


Topic: Въведение

List TV

Въведение

Встъпителни бележки

От автора на превода и българската редакция на [image] за

  • Предистория...

    С възможностите на ListTV се запознах "по неволя" - след дълго и безуспешно търсене на ТВ-програми във формат JTV за телевизионни предавания, които се излъчват в България...

    Всичко това от своя страна беше свързано с желание за по-пълноценно използване на всички възможности, които предоставя инвестицията в съвременен ТВ тунер Beholdеr с най-добрия софтуер (по оценка на всички, които са запознати с програмата) до тази момент - Behold TV.

    Въпреки известното недоверие в началото, програмата се оказа невероятно работоспособна, изпълнява безупречно всички функции и дори вече имаше български интерфейс (превод на български език - Георги Г. Милев ).

    Удоволствието и лекотата, с която се работи с ListTV е една от основните причини за написването този материал и доработката (редакция'2011) на българския интерфейс (превод: Beholder-Europe ).

    С надеждата, че материалът ще бъде полезен - приятно четене, с пожелание за лесно и успешно използване!

    Thebest@mail.bg

  • Предназначение, обхват и общи условия за ползване

    Материалите на български език се публикуват за улеснение на потребители, които срещат затруднения с оригиналния интерфейс на руски език.

    Целта на настоящата публикация е да бъдат преодолени затруднения с интерфейс, настройки и помощна информация при работа с програмни продукти на руски език, който се използва в такива при инсталиране по подразбиране. Стремежът е редактираните български преводи да обхващат всички достъпни раздели на официалните източници на производителите и други материали, свързани с процесите на инсталиране, настройки и работа със софтуера.

    Авторът на този материал няма претенции за пълна изчерпателност, както и за налагане на лични мнения и изводи по отношение на коментирания софтуер/хардуер. Материалите и използвани екранни снимки (screenshots), външни препратки (hyperlinks), самостоятелни разработки и пр. се публикуват за ползване при условия „As it is“:

    Авторът/редакцията не носят отговорност за възможни вредоносни въздействия върху системите и друг приложен софтуер под влияние на представяния по-нататък софтуер и съдържанието на цитирани интернет-препратки! Същите могат да бъдат използвани по собствена преценка, при съответните условия за ползване и изключително за своя сметка и риск.

  • Кратки бележки по превода и редакцията

    Този материал представлява разширен и редактиран превод на оригинален интерфейс, инструкции, Help-файлове и други публикации по темата в Мрежата. Използвани са източници и снимки (screen shots), публикувани на

    - официалния сайт на [image] ;

    - авторски материали, както и

    - статии, ревюта, коментари и публикации от други източници в интернет-пространството.

    * При превода, редактирането и графичното оформление на материалите на български език има някои особености, които са свързани с желанието същите да бъдат по-достъпни, изчерпателни и сравними. Тази информация е изнесена в българската секция към материалите.

  • Публикуване на информация

    Цитираните материали (препратки) са преведени въз основа на оригиналния интерфейс и Help към програмата.

  • Условия за ползване, тиражиране и разпространение

    Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията © ListTV ; The Best / Bulgaria . За нарушения се носи отговорност съгласно Закона за авторското право и сродните му права и международните правни норми за закрила на интелектуалната собственост.

  • Обратна връзка

    Авторът на превода и редакцията на инструкциите и други материали, свързани с представянето на фирмения софтуер на българския и европейския пазар с внимание и благодарност ще очаква всякакви коментари или забележки за установени евентуално допуснати неточности/грешки, както и отзиви във връзка с практическото ползване на фирмения софтуер.

The contents of Въведение

За ListTV
Инсталиране
От къде да се вземе програма?
Бързо стартиране
Системни изисквания


Topic: За ListTV

List TV

За ListTV

Какво представлява програмата

ListTV е удобен инструмент за преглед, обработка, разпечатване и експортиране в електронен формат на програми за телевизионни предавания ( [image] по-нататък за краткост съкр. само "предавания"/"програми").

За да бъде получена ТВ-програма в нужен вид е необходимо такава да бъде предварително (самостоятелно) свалена от Интернет или да бъде получена по друг начин в определен електронен формат. Подробен списък на сайтове и електронни пощенски абонаменти, чийто формат е "разбираем" за ListTV е посочен в раздел « От къде да се вземе програма? ». Достъпни са програми за над 200 телевизионни канала от много градове на Русия, [image] България , Украйна, Белорусия, Молдова, Киргизстан, Полша и спътниково излъчване, като списъците с канали и градове се допълват и обновяват.

Основни възможности:

  • Двуседмичен режим на изобразяване с възможности за сортиране и филтрация на данни;

  • Частична автоматизация на процеси по зареждане на файлове;

  • Управление на канали: наименования, емблеми (лого, логотип), индивидуално изместване по време;

  • Частично управление на ТВ тунер [image] (основни прости действия);

  • Поддръжка на анонси към предавания;

  • "Любими предавания": система от филтри за маркиране на любими предавания;

  • Напомняне за любими предавания;

  • Типове предавания: система от филтри за маркиране на типове предавания (филм, сериал, анимация и т.н.);

  • Печат и експорт на ТВ-програми;

  • Търсене по различни параметри;

  • Широки възможности за настройки на програмата според индивидуални потребителски предпочитания;

    ...


Topic: Инсталиране

List TV

Инсталиране

Инсталиране

Процесът на инсталиране е достатъчно опростен и преминава през няколко стандартни инсталационни прозореца.

Полезно: Още от първия екран може да бъде избран [image] език за интерфейс , при което следващите стъпки едва ли се нуждаят от подробни обяснения:

  • Изпълнява се инсталационният файл [image].

    В първия диалогов прозорец се предоставя възможност за промяна на език за следващите екрани и основния интерфейс от зададения такъв по подразбиране (руски):

  • Избор на език за интерфейс:

  • Встъпителни обяснения:

  • Лицензионни условия:

  • За продължаване се изисква [image] потвърждаване на съгласие с така дефинираните условия.

    При съгласие се предлага избор (промяна) на директория, в която да бъде инсталирана програмата (по подразбиране е зададена С:\Program Files\ListTV):

  • Следват опции за [image] избор на папки за съхранение на настройки и данни:

    и някои други [image] основни настройки:

  • Процесите по инсталиране се визуализират в информационна лента (progress-bar):

    Успешно инсталиране се оповестява в последния инсталационен прозорец:

  • Деинсталиране:

The contents of Инсталиране

Български интерфейс


Topic: Български интерфейс

List TV

Български интерфейс

интерфейс

  • При инсталиране на ListTV автоматично се зарежда вграден български интерфейс - превод на Георги Г. Милев .

    Промяна: В настоящата Help-версия са приложени екранни снимки, обяснения на менюта/команди и пр. въз основата на модифициран интерфейс. Причините за направените промени са посочени в т.2. на този раздел .

    При редактирането на промените спрямо първоначалния български интерфейс са положени усилия това да не налага никакви ограничения върху личните предпочитания на отделните потребители, като така направената редакция може изобщо да не се използва (въпрос на вкус). Всички основни диалогови прозорци, менюта, команди, опции и пр. в двете редакции на интерфейса са смислово еднозначни, като по никакъв начин не се засягат функционалните характеристики на програмата.

  • При желание да бъде ползван редактираният интерфейс (така, както е описан в тази инструкция) е необходимо да бъде направено следното:

  1. Препоръчително е оригиналният ресурсен езиков файл, който се намира в директория \Lang на самата програма (по подразбиране се инсталира в [image])

    да бъде запазен на отделно място, примерно в архивна (или друга) папка,

    от където при необходимост (предпочитане) да може да бъде възстановен лесно и бързо.

  2. В цитираната поддиректория \Lang трябва да се копира новият ресурсен файл [image], който е със същите атрибути като наименование и разширение...

    Програмата е готова за работа с новия интерфейс!

    Забележка: При промяна на желан език за интерфейс

    изменения се отразяват веднага - без рестартиране* на програмата:

    *Разбира се, необходим нов/друг ресурсен файл трябва да бъде копиран (да се намира) в посочената директория преди програмата да бъде стартирана, за да може да бъде инициализиран от същата.

  3. Забележка: Ресурсен езиков файл за редактираната версия на [image] интерфейс се предоставя безплатно.

    На този етап това се прави при поискване . В сферата на добрите намерения [image] е ресурсен файл (и следващи варианти, в случай че бъдат установени грешки или се наложи редактиране) да бъде предоставен на автора на програмата за публикуване на официалния сайт за download-версия, но доколко това ще бъде направено излиза от компетенциите на автора на този материал.

    Повече информация (евентуални корекции/допълнения, ТВ-програма във формат JTV и пр.) предстои да бъде публикувана също така в подходящ раздел на българската локация ( пак там ) на настоящия материал.


Topic: От къде да се вземе програма?

List TV

От къде да се вземе програма?

От къде да се вземе програма?

Към момента ListTV поддържа над 200 ТВ канала - източници на информация.

*Пълeн списък може да бъде намерен в оригиналния Help, а в случай, че програмата (респ. наличният Help-файл) не е обновявана продължително време - в сайта на ListTV - раздел « Телемания ».

**За целите на българската редакция в този материал са посочени само адреси на български език, като добрите намерения са този списък да се допълва и разширява периодично в подходяща форма (като електронни писма/абонаментно разпращане, в интернет-сайт, чрез Skype/QIP/Facebook и пр.). С голяма доза вероятност актуален списък ще се публикува на сайта на автора - beholder-europe.com

Списък с адреси на сайтове, в които се публикуват ТВ-програми на български език във формат, съвместим за работа с ListTV (в зависимост от системната поддръжка на съответните сайтове):

  • Dir.bg (България) ( http://media.dir.bg/tv.php );

  • Beholder-europe.com (формат JTV)

  • Beholder-europe.eu (формат JTV)

  • ...to be continued...

The contents of От къде да се вземе програма?

Списък
Телевизия/Лого


Topic: Списък

List TV

Списък

Списък с TV-канали и поддръжка на TV-програми във формат JTV

по адреси в Мрежата.

(Разпространение на национално ниво - ефипно и кабелно излъчване. Каналите са подредени по езиков признак; азбучен ред; латиница/кирилица. По-разширена информация, регионални канали и пр. - в раздел « Телевизия/Лого »)

Програма / Адрес | Жанр | Dir.bg
Български:
Balkanika MTV |  |
bbt |  |
BG_TV |  |
bTV |  |
bTV Action |  |
bTV Cinema |  |
bTV Comedy |  |
City TV |  |
Diema |  |
Diema 2 |  |
Diema Family |  |
MSAT |  |
NBT |  |
Pop Core TV |  |
Pro.bg |  |
Ring.bg |  |
T-Rock.TV |  |
T.TV.I |  |
The Voice |  |
TV+ |  |
TV1 |  |
TV7 |  |
Utilisima |  |
VTV |  |
БНТ Свят |  |
БНТ1 |  |
ВТК |  |
Евроком НКТВ |  |
Европа |  |
EBF |  |
Есет ТВ |  |
Канал 3 |  |
Нова Спорт |  |
Нова телевизия |  |
Планета |  |
Планета HD |  |
Планета Фолк |  |
ПО ТВ Тракия |  |
СКАТ |  |
Супер 7 |  |
Телекабел |  |
Тянков ТВ |  |
Фен ТВ |  |
Фиеста ТМ |  |
Фолклор ТВ |  |
Хоби ТВ |  |
Руски:
Охота и рыбалка |  |
Первый канал |  |
Планета_HD |  |
РТР Планета |  |
Русское телевидение RTVi |  |
Други:
Animal Planet |  |
ARD |  |
AXN |  |
AXN Crime |  |
AXN Sci Fi |  |
Baby TV |  |
Boomerang |  |
Box_TV |  |
Cartoon Network |  |
Cinemax |  |
Cinemax 2 |  |
CNN |  |
Community TV |  |
Crime & Investigation |  |
Da Vinci Learning |  |
Discovery Channel |  |
Discovery Science |  |
Discovery Travel and Living |  |
Discovery World |  |
Disney Channel |  |
Diva Universal |  |
DSF |  |
EKids |  |
ESPN America |  |
ESPN Classic |  |
Euronews |  |
Eurosport |  |
Eurosport 2 |  |
Extreme Sports Channel |  |
Fashion TV |  |
Fashion TV HD |  |
Film+ |  |
Fine Living Network |  |
Food_network |  |
FOX Crime |  |
FOX Life |  |
HBO |  |
HBO Comedy |  |
History |  |
History HD |  |
JimJam |  |
Kabel_1 |  |
Mad_TV |  |
MCM |  |
MGM |  |
Motors TV |  |
MTV |  |
MTVHD |  |
myZen.tv |  |
Nat Geo Wild |  |
National Geographic |  |
NBT |  |
Playhouse_Disney |  |
Pop_Core |  |
ProSieben |  |
RTL |  |
RTL2 |  |
SAT 1 |  |
Sky Sports |  |
TCM |  |
TLC Balkans |  |
Travel Channel |  |
Travel_HD |  |
Travel_TV |  |
VH1 |  |
VH1_Classic |  |
Viasat Explorer |  |
Viasat History |  |
Viasat Nature |  |
Viasat TV 1000 |  |
VOX |  |
VTV |  |
Zone Reality |  |
Zone Romantica |  |
To be continued... |  |


Topic: Телевизия/Лого

List TV

Телевизия/Лого

n.a.(преместено) - Поради значително нарасналия обем този раздел е обособен в отделен материал - вж. " полезни връзки ".


Topic: Бързо стартиране

List TV

Бързо стартиране

Бързо стартиране

Пример (на базата на Dir.bg):

  • При зареждане на програма от сайт:

    - в браузъра се избира съответния адрес: http://media.dir.bg/tv.php ;

    - избират се необходимите опции (ден / седмица, канали, жанр...) и се натиска бутон [image];

    - след пълно зареждане се избира действие за съхраняване: «Файл»-«Съхраняване на страница като...»:

    - указва се тип за файл - «Уеб-страница, само HTML»;

    - HTML страницата се съхранява в избрано място, откъдето ще се зарежда в ListTV

Зареждане в ListTV - бутон [image] ( [image] вж. също « Настройки за зареждане на данни »)

В диалоговия прозорец за зареждане се указва:

  • тип на файл: «Dir.bg»;

  • кодиране: «Автоматично»;

    Процесът на зареждане се визуализира в реда за състояние и отнема различно време (до няколко минути - в зависимост от обема на програмите (период, брой програми) и възможностите на конкретната система. При наличие на предишна база данни, до обработката на нова такава с статусния ред се вижда информация за предходния период,

    която се обновява при успешно завършване на процеса:

    Нормално заредени програми се визуализират в следния вид:

  • При получаване на ТВ-програми като електронна поща / абонамент и пр.:

    - съхраняват се получените файлове с програми на диск;

    - в диалоговия прозорец за зареждане се указва:

    тип на файл: «Dir.bg»;

    кодиране: «Автоматично»;

    - ако писмата са във формат MIME - да се зададе отметка [image] «base64»;

    - ако актуализация е по FIDO - да се зададе отметка [image] «Заменяне на 'Н' и 'р'»...

    Програмата е готова за работа!


Topic: Системни изисквания

List TV

Системни изисквания

Системни изисквания

Минимални изисквания за нормална работа на ListTV:

  • IBM PC съвместим компютър с процесор 486 и по-мощен;

  • 4 МВ свободна памет;

  • Около 1 МВ свободно дисково пространство (без да се имат предвид файлове с данни);

  • ОС - Microsoft Windows 95, NT 4.0 (или следващи версии);

  • SVGA видеокарта в режим High color mode (желателно).

Доколкото ListTV използва някои особености на Windows 95 и NT, програмата не може да работи в Windows 3.х с Win32s или в Windows NT - версии под 4.0.

Програмата не е тествана под емулация на Windows или алтернативни среди.


Topic: Основни възможности

List TV

Основни възможности

Основни възможности

The contents of Основни възможности

Главен прозорец
Търсене
Печат
Експортиране


Topic: Главен прозорец

List TV

Главен прозорец

Главен прозорец

Прозорецът има достатъчно опростен, "интуитивен" интерфейс :

  • Меню - основна лента:

  • Панел с инструменти, който дублира основните функции на менюто чрез икони:

  • Период от време:

  • Основен прозорец:

    В лявата част се намира "дървовидна" структура (по-нататък съкр. също така «дърво...») по дни и канали:

    В дясната част е основният списък с предавания:

    При маркиране на възел [image] (Пн...Нд...Вси=Понеделник...Неделя...Всички) в "дървовидната" структура,

    в списъка с предавания се изобразяват ТВ-програми.

  • В списъците с предавания е възможно сортиране по произволно избрана колона. За това е достатъчно да се натисне заглавие на съответна колона [image].

    При повторно натискане се извършва сортиране в обратна посока. Сортиране се извършва в следния ред: "Избрана колона"-"Ден"-"Време".

  • Под списъка с предавания се намира прозорец с анонси [image]. Показване на този прозорец (респ."видимост") се регулира чрез отделна настройка, която е достъпна от прозореца за настройки- [image] и меню [image] - "падащо" подменю [image].

    Възможни са корекции или внасяне на собствен потребителски анонс. Ако прозорец с анонси не се показва е достатъчно да се [image] кликне с мишката в клетка от колона «Анонс» [image] и прозорецът ще се появи (независимо от настройките за видимост).

  • В долната част на прозореца се намира ред за статус:

    В него се изобразяват:

    - количество предавания в таблицата,

    - диапазон от дати, за които има програма, а

    - в лявата част - информационен прозорец за напомняне [image], в който се извеждат

    §брой напомняния за текущия ден,

    §настройки за работа с «напомняния» (~reminder).

    При двоен клик с левия бутон на мишката върху [image] число (брой) напомняния се извежда информационно съобщение за текущи напомняния.

    При двоен клик с левия бутон на мишката върху изображение на [image] прозорец или [image] високоговорител се превключват съответните режими на работа за напомняне (със съобщения/без съобщения, със звук/без звук).

    При клик с десния бутон на мишката върху ред с предавания се извиква контекстно меню (за момента интерфейсът на този диалогов прозорец е на руски език),

    в което могат да бъдат извършвани следните действия:

  • търсене (рус.«Поиск») на избрано предаване:

  • добавяне в списък с "любими" предавания

    добавяне в класификатор

  • проверка по ключова дума за тип на предаване

    ? Забележка: опцията е активна в "падащото" меню само при наличие на зададен "тип" [image] за предаване

    ,

    в противен случай този ред не се показва

    При стартиране на тази опция се извършва търсене/обработка в базата

    и в случай на положителен резултат се визуализира (маркиран) съответен ред с предаване, което съдържа съответната ключова дума

  • изменение на настройки (рус.«Свойства») на канал:

  • копиране в буфера (clipboard), както и

  • бързо изменение на

    рейтинг [image] и тип [image] на предаване.

    Бързо изменение на рейтинг също така е възможно чрез "горещи" клавиши (Ctrl+0...Ctrl+9).

  • Ако таблицата със списък от програми се намира на фокус, могат да се използват клавиши [image] «Наляво» и «Надясно» [image] за преместване към съседни секции [image], при което List TV ще се старае да намери в списъка с програми тази, на която потребител се намира в дадения момент.

  • При двоен клик върху ред с програма на предавания (клавиатурен еквивалент на «Enter») е възможно превключване на ТВ-тунера на канал с избрано предаване, ако са направени съответни настройки в прозорец « Канали » (ако има инсталиран работещ ТВ-тунер, разбира се).

  • Филтрация - меню

    или бутони [image]:

    При «Филтриране по тип предаване» се отваря допълнителен панел с бутони за настройки на филтър за типове:

    Аналогично, при «Филтриране по рейтинг» се отваря допълнителен панел с бутони за настройки на филтър за "любими" предавания: . При използване на бутони със съответни изображения, могат да се групират предавания за гледане.

    При «Филтриране по анонси», предаванията в таблицата се филтрират по наличие на анонси.

    При «Филтриране по напомняне» могат да се видят всички предавания, за които има зададен признак за напомняне.

  • За всички бутони в панелите и за болшинството опции (команди) в менютата са зададени еквивалентни клавишни комбинации . За свиване на прозореца се използва клавиш «Esc».

    Към всички бутони на панел с инструменти има прикрепени "изплуващи" подсказки (hint~s). За да се види предназначение на бутон е достатъчно просто да бъде насочен курсорът на мишката към такъв, за да се прочете съответната подсказка.

  • Външният вид на прозореца по възможност подлежи на максимални настройки:

    меню, панел с бутони и ред за състояние под прозореца могат да бъдат изключвани/включвани чрез съответни команди от менюто.

    Внимание [image] Не се препоръчва без необходимост да се експериментира със следващите опции - при пробно тестване се получи известен срив, в резултат на който "скрити" главно меню и лента с инструменти не можаха да бъдат възстановени по описания по-долу начин. За предотвратяване/отстраняване на възможни такива (и евентуални други неоткрити) проблеми да се процедира по следния начин:

    - преди извършване на промени да се запази в отделно място конфигурационният файл [image] от работещо приложение;

    - в случай на възникване на проблем- с този файл да бъде заместен едноименния такъв в основната директория на програмата, при което се "възстановява" положението към момента на запазване на въпросната "работеща" конфигурация.

    ...

    Ако е премахнато показване на главното меню [image] и [image], в контекстното меню на главния прозорец се показва нова опция [image], от която може да бъде възстановен външният вид.

  • Също така са възможни настройки за видимост и местоположение на различните колони в таблицата:

    - видимост се настройва с помощта на контекстното меню в заглавието ( [image] десен клик) в заглавието:

    - местоположение на колони се сменя чрез "влачене";

    Допълнителни настройки на външния вид могат да бъдат задавани в прозорец « Настройки ».

  • При зареждане на програмата автоматично се активира страница [image] (ако в настройките не е зададено друго):

    В списъка на страницата се извеждат всички предавания (по всички активни канали), които текат в текущия момент (и следват веднага след този момент, ако е зададена съответната опция [image]). По желание е възможно да се зададе всякакъв интервал от време, за който да се изобразяват предавания:

    - ако се зададе отметка [image], то в дясно от списъка се появява плъзгач [image], с който може да се промени горната граница на интервала, при свалена отметка [image] - още един плъзгач [image] за изменение на долната граница.

    При свалена отметка [image] също така става достъпен "падащ" списък [image], в който може да се избере необходим ден и да се види какви предавания ще има в този момент от време.

The contents of Главен прозорец

Клавишни комбинации


Topic: Клавишни комбинации

List TV

Клавишни комбинации

Клавишни комбинаци - «Горещи» клавиши

Действие/Команда | Бутон/Съчетание
Свиване | Esc
Зареждане | Alt+Load
Експортиране | Alt+S
Печат | Alt+Print
Търсене | Alt+Find
На страница «Сега» | Alt+1
На страница «По дни» | Alt+2
На страница «По канали» | Alt+3
Скриване/показване на главното меню | Alt+Menu
Скриване/показване на панела с бутони | Alt+Buttons
Филтрация по тип предавания | Ctrl+Type
Филтрация по рейтинг | Ctrl+Rating
Филтрация по напомняне | Ctrl+E
Филтрация по наличие на анонси | Ctrl+Anounce
Общи настройки | Alt+O
Класификация (типове) предавания | Alt+Type
Настройка на рейтинги (любими) | Alt+Rating
Настройки на канали | Alt+Channel
Настройки на анонси | Alt+Anounce
Помощна информация/Help | F1
Често задавани въпроси/F.A.Q. | Shift+F1
За програмата | Alt+F1
Регистрация | Shift+Ctrl+Register
Изход | Alt+eXxit
Изменение на рейтинг | Ctrl+0...Ctrl+9
Превключване на канал в ТВ-тунер | Enter
Преход към съседна страница | Наляво/Надясно


Topic: Търсене

List TV

Търсене

Търсене

Настройките на параметри за търсене са единни за търсене, експортиране и печат. Търсене на предавания е възможен по всякакви критерии

  • по избор на канали, дни, време, типове предавания, рейтинг, а също така

  • по набор от ключови думи (фрази) и алгоритъм "Съдържа-не съдържа", т.е. присъстващи и отсъстващи в наименование на предаване. Думи (фрази) вътре в такъв набор трябва да бъдат разделяни със символ « ; ».

    Ако не е избран нито един критерий, този параметър за търсене няма да бъде използван.

    Така например, ако не е отметнат нито един канал, това е равнозначно на подразбиране, че са отметнати всички канали.

    Превключване между списъци с дни, канали, типове и рейтинги се извършва с натискане на съответните бутони. За удобство при работа със списък може за се използва локално меню, което "пада" при натискане на [image] десния бутон на мишката. Същото съдържа три опции:

  • Ако е необходимо да бъдат съхранени критерии на филтър до следващ сеанс на работа се задава отметка в «чекбокс» [image].

  • Ако в списък с предавания бъдат намерени програми, които отговарят на зададените критерии, такива ще бъдат изведени в прозореца с резултати от търсене. Намерени предавания могат незабавно да бъдат експортирани във файл или да бъдат разпечатани.

Забележки:

  • Търсене на ключови думи (фрази) в наименования на предавания не е чувствително към регистъра.

  • Търсене се извършва само по канали, за които е зададена опция за "видимост";

  • За всички намерени предавания може да бъде променян рейтинг или тип. За целта се използва контекстното меню в списъка с програми в прозореца за търсене.

  • В списък с намерени програми се поддържа сортиране по колони (необходимо е да се натисне върху заглавие на съответната колона с курсора на мишката; при повторно натискане се извършва сортиране в обратен ред).


Topic: Печат

List TV

Печат

Печат

The contents of Печат

Предварителен преглед
Параметри за печат
Клавишни комбинации за печат


Topic: Предварителен преглед

List TV

Предварителен преглед

Предварителен преглед

При необходимост програма с предавания може да бъде отпечатана, при това в предпочитан вид. При натискане на бутон «печат» в главния прозорец се отваря прозорец за предварителен преглед:

Описание на иконите и свързани с тях действия:

В горната част на панела с бутони са разположени:

  • «Принтиране» [1] - започва процедура за печат. При натискане на бутона се извежда стандартен диалогов [image] прозорец, в който могат да бъдат зададени номера на страници за отпечатване, както и някои други настройки, свързани с параметри на принтер:

    Внимание [image] Не се препоръчва в този диалогов прозорец да се променят размери (формат) на лист и ориентация, т.к. при това няма да бъде извършено ново пресмятане на количеството страници и извеждане на данни за печат ще бъде извършено неправилно. За такива цели е предназначен следващият бутон.

  • «Настройки на принтер» [2] - избор на принтер и задаване на някои други настройки, например размери (формат) на лист и ориентация на страници.

    При натискане на бутон [image] в този диалогов прозорец ще бъде извършено преизчисляване на количеството страници;

  • «Какво ще се принтира?» [3] - извежда се прозорец с параметри за подбор на предавания за печат, аналогичен на прозореца, който се използва за търсене . Възможно е ограничаване на количеството извеждана за печат информация в съответствие с конкретните потребности:

  • «Как ще се принтира?» [4] - извежда се диалогов прозорец с параметри, които позволяват да се променя шрифт, отстъп от границите на лист и между колони с текст, други параметри за печат;

  • следват

  • четири бутона [5] за «преместване по страници», които са подготвени за печат;

  • «падащ» списък [6], с помощта на който може да се избира «мащаб» на изображение;

  • два бутона за оптимално поместване на изображение за преглед -

    «По широчината на екран» и

    «По височината на екран» [7].

Забележка: Мащабиране също така може да се променя с натискане на

десeн бутон на мишката (намаляване) и

ляв бутон на мишката (увеличаване) върху изображението на документ за печат, както и с

клавиши « + » и « - ».

  • В края на панела има бутон за извикване на «помощна информация» и

  • бутон «Изход» [8].

  • Практически на всички бутони в прозорците съответстват клавишни съчетания .

В долната част на прозореца е разположен ред за статус [9] [image] с указания за текущата страница и общо количество страници.

Предавания, които попадат в категория "любими" се отбелязват с цифри в зависимост от получения рейтинг - в ляво от времето за излъчване.

Предавания, които се задават в списък за напомняне се отбелязват с подчертаване.


Topic: Параметри за печат

List TV

Параметри за печат

Параметри за печат

Настройки на външния вид на отпечатвани страници са събрани в дървовидната структура на прозорец «Как ще се принтира?» и функционално са разпределени в следните групи:

За бързо преместване между групите може да се използва панелът с бутони в лявата част на дървовидната структура. Самото "дърво" за настройки се състои от две колони:

  • Позоваване на параметър зависи от неговия тип.

    Така например,

    - ако параметър е прост превключвател, е необходимо просто да се кликне с [image] левия бутон на мишката по отметката в ляво от наименованието.

    - ако параметър изисква числово въвеждане или извикване на диалог за изменение на цвят или шрифт, то е необходимо да се премине в колона «Значение», след което ще се появи елемент за управление (бутон за извикване на диалог или прозорец за въвеждане на число), който позволява да се внесат изменения в параметър.

Накратко за групите за настройки:

  • Група « Начин на отпечатване »:

  • Група « Параметри на страница »:

  • Група « Шрифт »:

  • Група « Разни »:

The contents of Параметри за печат

Начин на отпечатване
Параметри на страница
Шрифт
Разни


Topic: Начин на отпечатване

List TV

Начин на отпечатване

Група «Начин на отпечатване»

«Ден-канал» - печата се по блокове: програма с предавания за един канал за един ден;

«Всички канали за един ден» - печата се по блокове: програма с предавания за всички канали за един ден, със сортиране по време;

«Всички ден с нова страница» - печат на програми за всеки ден започва от нова страница;

«Първо нечетни страници» - при задаване на тази опция в началото се печатат нечетни страници, след което - четни. Това е удобно, например ако се принтира от двете страни на лист на принтер, който не поддържа двустранно печатане;

«Двустранно принтиране» - ако се използва тази настройка, то печат на колонтитули и използване на отстъпи зависи от това, каква страница се печати - четна или нечетна.


Topic: Параметри на страница

List TV

Параметри на страница

«Параметри на страница»

Група от настройки, които позволяват да се настрои външния вид на страница (печат на колонтитули, количество колони на страница и отстъп от границите на лист и между колоните).

Количеството колони не може да бъде над 10, въпреки че на практика едва ли е целесъобразно да се разпечатва текст на повече от 5 колони.

По подразбиране разстоянието между колоните се задава равно на 5 мм. Отстъпи от границите на лист се задават с равни стойности, които се получават от драйвера на принтера и не могат да бъдат по-малки от величините, ограничени от свойствата (properties) на принтера.


Topic: Шрифт

List TV

Шрифт

Група «Шрифт»

Група от настройки, които позволяват да се зададе шрифт за основния текст и за текст на заглавия над блоковете с програми на предавания.

Размерите на шрифт за заглавия не трябва да превишават повече от два пъти тези на шрифт за основния текст.


Topic: Разни

List TV

Разни

Група «Разни»

«Принтиране на колона "До"» и

«Принтиране на анонси» - определят обема на извеждана за печат информация;

«Оформление на заглавие» - определяне на външния вид на заглавия над блокове с програми на предавания;

  • При натискане на бутон [image] настройките се съхраняват в .ini-файл.


Topic: Клавишни комбинации за печат

List TV

Клавишни комбинации за печат

Клавишни комбинации за печат

Работа с прозорец за печат с помощта на клавиатура («клавишни съчетания»):

Опция | Комбинация
Печат | Alt+Print
Настройки на принтер | Alt+O
Какво се печата? | Alt+What
Как се печата? | Alt+How
Помощна информация / Help | F1
Изход | Esc
Първа страница | Alt+Home
Предишна | Alt+Left
Следваща | Alt+Right
Последна | Alt+End
Увеличаване на мащаб | « + »
Намаляване на мащаб | « - »


Topic: Експортиране

List TV

Експортиране

Експортиране

Ако е необходимо, ТВ програма може да бъде експортирана във файл. Подбор на предавания за експорт се извършва в аналогичен прозорец на този за търсене . Ако търсене на предавания е било успешно се извежда прозорец, в който могат да бъдат задавани параметри на файл за съхранение на информация:

При потвърждение [image] се отваря диалогов прозорец:

  • Тип на експортиране:

«Ден-канал» - извеждане по блокове: програма с предавания за един канал за един ден;

«Всички канали за един ден» - извеждане по блокове: програма с предавания за всички канали за един ден, със сортиране по време;

«JTV guide» - данните се съхраняват в специален формат JTV - приложение за използване на програми с ТВ-тунер)

Информация за работа с ТВ тунери Beholder е поместена в отделен раздел.

  • Допълнителна информация:

Извеждане на колона «До»;

Извеждане на анонси -

При необходимост се отмятат съответните опции.

При потвърждение [image] се отваря диалогов прозорец с параметри за съхранение на файл:

В него може да се избира папка и да се указва формат и име за файл. Успешно експортирани файлове се визуализират в следния вид:

  • Важно! ListTV поддържа следните формати файлове:

    «текст», «html» и «csv» (текст с разделители).

    Имената на папка и файл се съхраняват в .ini-файл.

    За работа с Agent Behold TV е необходимо файловете да бъдат компресирани в .zip архив:


Topic: Настройки

List TV

Настройки

Настройки

Болшинството инструменти за настройки на програмата са групирани в структурата на прозорец «Настройки» и функционално са разпределени в следните групи:

  • Описание - « Общи настройки »:

The contents of Настройки

Общи настройки
Настройки за зареждане на данни
Класификатор (типове) на предавания
Рейтинги (Любими предавания)
Настройки на канали
Настройки на анонси
Настройки на тунер


Topic: Общи настройки

List TV

Общи настройки

За бързо преместване между групи може да се използва панелът с бутони в ляво от "дървото". Самото "дърво" за настройки се състои от две колони - «Параметър» и «Значение» (атрибути на параметър). Препратка към даден параметър зависи от неговия тип:

Така например, ако параметър е прост превключвател (т.е. без [image] опции за избор), е необходимо просто [image] да се кликне с левия бутон на мишката по отметката в ляво от наименованието.

Ако даден параметър изисква въвеждане на число или извикване на диалогов прозорец за изменение на цвят или шрифт, е необходимо да се премине към колона «Значение», след което ще се появи елемент за управление (бутон за извикване на диалог или прозорец за въвеждане на число), който позволява да се внесат @ изменения в съответния параметър.

Понякога е необходимо да се изпълнят и двете операции - например, ако е необходимо да се измени цвят на фон за таблица. За целта се извършва следното:

  • натиска се бутон «Външен вид» [image] "дървото" се отваря в нужната група;

  • колона «Значение» срещу възел «Цвят на фон» е оцветена с избран цвят;

  • във възел «Цвят на фон» има три опции:

    «По подразбиране»,

    «Системен»;

    «Произволен»;

  • При натискане върху превключвател се вижда как цветът в клетка «Значение» във възел «Цвят на фон» се променя;

  • Ако даден превключвател е в положение «Произволен», то в колона «Значение» се появява бутон [image] («Промени»), при натискане върху който се извиква стандартен диалогов Windows-прозорец за избор на цвят:

Накратко за групите за настройки:

  • Външен вид ;

  • Показване ;

  • При стартиране ;

  • Време;

  • Напомняне;

  • Съхраняване ;

  • Разни

The contents of Общи настройки

Външен вид
Показване
При стартиране
Време
Напомняне
Съхраняване
Разни


Topic: Външен вид

List TV

Външен вид

Група «Външен вид»

Настройките в тази група имат следното предназначение:

  • За определяне на външен вид на бутоните в горния панел на главния прозорец и прозореца за печат.

  • За изменение на шрифт, използван в програмата. При натискане на бутон [image] («Промени») се извиква стандартен диалогов Windows-прозорец за избор на шрифт.

    Размерите за шрифт са ограничени в диапазон от 6 до 13 пункта. Може да се задава отделен шрифт за таблици с ТВ-програми.

  • За изменение на цвят на текст, подсказки и фон за таблици.


Topic: Показване

List TV

Показване

Група «Показване»

«Главно меню», «Лента с инструменти», «Лента за състояние» - изобразяване на елементи от главния прозорец;

«Колони и редове в таблица» - изобразяване на мрежа в таблиците;

«Картинки в "дървото"» - изобразяване на икони в "дървото" на главния прозорец;

«Лого на канали в таблица» и «Номер на канал в таблица» - изобразяване на информация за канал в таблиците на главния прозорец;

«Пълен текст (наименование) на предаване в подсказка» - ако наименование на предаване е твърде дълго, за да бъде видяно изцяло, без да се разширяват колони става възможно в "изплуваща" подсказка;

«Предавания за целия ден (канал), при маркиране на ред в левия прозорец» - при маркиране на съответен възел в "дървото" с дни (канали) в таблицата ще се изобразяват всички предавания за избран ден/за избран канал;

«Предавания за цялата седмица, при маркиране на ред в левия прозорец» - при маркиране на съответен възел в "дървото" с дни (канали) в таблицата ще се изобразяват всички предавания за седмицата;

«Анонси, при избор (маркиране) на предавания» - маркиране на предаване в таблицата, под прозореца ще се изобразява прозорец с допълнителна информация (анонс). Съдържанието на този прозорец е достъпно за редактиране.

Така например, в същия могат да бъдат внесени лични бележки.


Topic: При стартиране

List TV

При стартиране

Група «При стартиране»

«Да не се показва заставка» - изключване показване на заставка при стартиране на програмата.

«Отваряне на страница» - позволява избиране на заставка в главния прозорец, която да се отваря при първо зареждане на програмата.

«Прозорец» - позволява задаване на състояние на прозореца при стартиране (свит, максимизиран или обемен).

«Показване на текущи напомняния» - ако тази опция е активирана, при стартиране ще бъде показан прозорец за напомняне с предавания, които имат рейтинг за «Напомняне».


Topic: Време

List TV

Време

Група «Време»

  • «Начало/Край на предавания» - позволява да се зададе граница за показване на предавания (особено актуално за канали с денонощно излъчване). При избор на определен ден, в таблицата ще бъдат показани предавания от зададеното време до края на денонощието, плюс предавания от следващите денонощия до зададеното време.

«Времеви диапазон на страница «Сега» - позволява да се зададе диапазон от време, през което да се показват предавания при активирана отметка [image] «и до...» на страница [image] . Действа при всяко обновяване на информацията за тази страница.

Горната граница на диапазона може да бъде зададена постоянна или относителна спрямо

долната граница на диапазона.

При активирана отметка «Запомни последното значение», нейното действие зависи от това, какъв тип на диапазон е зададен:

Ако диапазонът е относителен се запомня количеството минути в интервала, а

Ако диапазонът е постоянен се запомня величината на горната граница.

«Ако крайно време не е известно, ще бъде установено чрез...» - задаване на продължителност на предавания (обикновено последни в списъка с ТВ-програми), за които не е известно времето на завършване. Тази стойност може да бъде зададена или като фиксирана величина, или да бъде пресметната (извадена) от времето на началото на първото предаване за следващия ден.


Topic: Напомняне

List TV

Напомняне

Група «Напомняне»

«Включване» - разрешаване/спиране на напомняне;

«Ограничаване на време за работа на напомняне» - позволява (при необходимост) да се задава времеви диапазон за работа на напомняне за различни дни от седмицата.

«Точност» - в случай, че на компютъра не се изпълняват някакви обемни задачи, степента на точност е по-добре да се остави «нормална», т.к. всяка друга величина води до допълнително натоварване на процесора.

Отделно може да се [image] включва/изключва прозорец и [image] звук за напомняне, като

за прозорец със съобщения може да се избира шрифт, както и да се определят някои параметри на неговата работа:

  • «Да не се показва при работа с пълноекранни приложения (игри, филми и т.н.)» - ако се зададе тази опция, прозорец за съобщения няма да се показва, дори ако е зададена опция [image] «Съобщение» (с изключение на ситуация при която работи приложение та ТВ-тунер в пълноекранен режим);

  • Ако не е нужно напомняне и при работа на ТВ-тунер, се задава опция [image] «С включване приложение на ТВ-тунера»;

  • «Автоматично затваряне на прозореца за съобщения» - след показване на прозореца за съобщения, същият може или да бъде затворен от потребителя, или това да бъде предоставено на самата програма, като се зададе съответната настройка;

  • «Звук» - Звуково оповестяване е възможно

    «PC Speaker» - чрез вградения високоговорител на компютъра,

    «Системен» - в съответствие с настройките на Windows (в «Control panel»),

    от «Файл» във формат .wav.

  • Последната настройка в тази група позволява задаване на време за сработване на напомняне няколко минути преди началото на предаване.

Функциите за включване/изключване на напомняне са достъпни също така от контекстното меню в трея (tray).


Topic: Съхраняване

List TV

Съхраняване

Група «Съхраняване»

Подгрупа « [image] »:

  • «Състояние на прозорци» - позволява запомняне на размери, положение и състояние на прозорците на екрана при завършване на работа;

  • «Широчина и сортиране на колони в таблица» - позволява да се съхраняват съответните параметри;

  • «Настройки за отпечатване» - програмата ще съхранява всички настройки, зададени в прозорци «Какво ще се принтира?» и «Как ще се принтира?»;

Подгрупи« [image] » и « [image] » - избор за съхраняване на настройки/данни в една от три възможности:

  1. в папката, в която е инсталирана ListTV (от където се стартира ListTV.exe);

  2. общо хранилище за данни (Application Data) - папка, в която Windows пази данни за програми. Така например,

    в Windows Me това може да бъде папка «С:\Windows\ApplicationData», а

    в Windows ХР - «С:\Documents and Settings\User\Application Data»;

  3. общо хранилище за документи (папка «Мy Documents»);

При избор на опции 2. или З. в избраната папка се създава подкаталог «\ListTV», в който програмата ще съхранява своите настройки/данни. Избор на тази настройка, както и положението на тези папки се определя автоматично при пускане на ListTV чрез търсене в ListTV.ini и ListTV.dat.


Topic: Разни

List TV

Разни

Група «Разни»

  • «Намаляване до systray» - при активирана опция програмата се помества при свиване като иконка в системния трей;

    Възстановяване се извършва с [image] еднократен или [image] [image] двукратен клик с мишката, в зависимост от [image] зададените опции.

  • «Винаги да се показва икона в systray» - при активирана опция иконка на програмата се зарежда в системния трей, независимо дали прозорецът е свит или не;

  • «Намаляване при бездействие след...N минути» - Ако не се извършват никакви действия в ListTV, след указания период от време програмата се свива;

  • «Затваряне на програмата само при натискане на бутон "Изход"» - при активирана опция и натискане на системния бутон [image] «Затваряне» програмата няма да се затваря, а ще се свива.

    От режим на работа в tray - [image] с [image] десен клик върху иконката са достъпни следните команди/опции:

  • «Да не се стартират две копия на програмата» - при активирана опция се предотвратява пускане на второ копие на програмата;

  • «Синхронизиране на сортиране на колони в таблица» - при активирана опция във всичките три таблици ще се поддържа сортиране по една и съща колона (по възможност). При изключена - за всяка таблица остава свой ред за сортиране.

  • «Зареждане с Windows» - при активирана опция ListTV ще се зарежда при стартиране на Windows;

  • «Прехвърляне фокуса на списък при посочване с курсор върху него» - при преместване на курсора на мишката в областта на "дървовидна" структура или на списък, фокусирането автоматично ще се предава в този елемент на прозореца, т.е. съответният елемент става активен и реагира на команди от клавиатурата.

  • «Копиране в буфера за обмен» - позволява да бъдат избрани параметри на предавания, величините на които ще бъдат копирани в буфера при изпълнение на съответна команда от менюто в списъка с предавания.

Забележка: в програмата автоматично се съхраняват:

  • състояние на превключватели: «Филтър за типове предавания», «Анонси» и «само любими» - текущи набори с филтри за типове предавания и рейтинг;

  • състояние на превключвател «и до ...».

    При натискане на бутон [image] настройките се съхраняват в .ini-файл.


Topic: Настройки за зареждане на данни

List TV

Настройки за зареждане на данни

В лявата част на прозореца се намира списък със сайтове, информацията от които може да бъде използвана в програмата.

Ако не е необходимо да се използват данни и настройки на някой от сайтовете в диалоговия прозорец при зареждане, е достатъчно да бъде свалена отметката в ляво от наименованието на сайт. Ако не се използва нито един сайт, диалоговият прозорец за зареждане не се показва, а програмата издава съответно съобщение.

  • В група «Кодиране» се задава тип за кодиране на изходните файлове:

    Ако програма с предавания се получава по електронна поща е възможно да се наложи да се зададе опция за прекодиране на текст от формат base64 (MIME).

    Ако програма пристига по FIDO е възможно да се наложи да се зададе опция за замяна на латински букви "Н" и "р" с кирилица (руски), които са сходни по графични очертания.

  • Група «Каталог за зареждане» е предназначена за настройки на каталог и маски на файлове, които подлежат на зареждане.

    Внимание [image] Доколкото за обработка на файлове от различни сайтове се използват различни алгоритми, е необходимо за всеки сайт да се задават или отделен каталог, или маска на файлове, различни от другите сайтове. В противен случай са възможни сривове в програмата.

    Наименование на каталог може или да се въведе в полето в ляво от бутон [image], или да бъде избран с помощта на този бутон. Маска на файл се въвежда в полето, разположено срещу надпис «Маска на файлове, по подразбиране».

    Внимание [image] Да се избягва задаване на маска тип «*.*», т.к. при погрешно указване на каталог могат да бъдат изгубени всички файлове от този каталог при зададена опция [image] «Изтриване на файлове след обработка».

    Така например, настройки могат да бъдат следните:

    За всички сайтове се указва каталог: C:\LISTTV\LOAD\... и маска на файлове (за "Dir.bg": *.cat) . При автоматично зареждане програмата ще сканира указания каталог за търсене на файлове със съответно разширение, като в случай на успех ще приложи към тях необходима процедура за обработка, след което файловете ще бъдат премахнати (в "кошчето").

  • Група «Общи за всички файлове» е предназначена за избор на тип за зареждане [image]:

    § Зареждане «С помощта на диалогов прозорец за зареждане» - При натискане на бутон «Зареди» се извиква диалогов прозорец, в който може явно да се указва зареждан файл, неговата кодировка, както и допълнителни действия, които е необходимо да бъдат извършени с файла.

    § Зареждане «При натискане на бутон «Зареди» - При натискане на бутон «Зареди» автоматично се зареждат файлове в съответствие със зададени опции за зареждане.

  • «Автоматично, при стартиране» - при всяко стартиране програмата ще сканира каталозите, указани в настройките и ако намери файлове ще ги зарежда.

    «Изтриване на файлове след обработка» - ако е активирана тази опция, обработени файлове ще бъда премахнати (в "кошчето"). Ако е избрано «Автоматично, при стартиране» тази опция се маркира като "зададена" и не подлежи на изменение.

  • В група «Обработка на данни» има две настройки:

    «При съвпадение на дни от седмица, канал и време на предаване» - избор на режим за обновяване на данни:

    Тази настройка е актуална ако се използват ТВ-програми от различни сайтове или при повторно зареждане на данни.

    «Пренасяне на част от описанието в анонс - след знак...» - при някои сайтове в наименованието на предаване се намира и анонс. Това може би е удобно при гледане, но пречи при разпечатване (и в някои други случаи). При активиране на тази настройка част от по-дълго описание може да бъде пренесена в анонс за предаване, който не се изобразява непосредствено в таблица.

Забележка: Файлове не се преместват в "кошчето", ако програмата не е могла да ги разпознае. Необходимо е да се внимава - ако е зададено автоматично зареждане, при следващо стартиране на програмата същата ще се опита да зареди такива отново.

При натискане на бутон [image] настройките се съхраняват в .ini-файл.

The contents of Настройки за зареждане на данни

Зареждане на данни
Съобщения при зареждане на данни


Topic: Зареждане на данни

List TV

Зареждане на данни

Зареждане на данни

Под «Данни» тук се подразбират

  • получени по електронна поща (абонамент и пр.) програми за предавания

  • или HTML с програми, свалени от сайтове, форматът на които се поддържа от програмата.

    Необходимо е да се внимава - при някои сайтове се поддържа само формат за абонаментно разпращане или формат на архив, който се пази в съответния сайт.

ListTV работи с файлове с кодировка Windows 1251, DOS 866 или KOI-8R и е способна коректно да разпознава данни във формати .txt, .eml и .html.

  • Ако се зарежда абонамент във формат .eml - да се провери в какъв формат са данните;

  • Ако е MIME (в текста на eml-файл има ред «Content-Transfer-Encoding: base64»), в диалоговия прозорец за зареждане (или в настройките за зареждане) е необходимо да се зададе опция [image] «base64».

  • Ако се получава като FIDO - разпращане, може да се наложи да се зададе опция [image] «Заменяне на 'Н' и 'р'».

Доколкото анонси за ТВ-програми се пазят във файл с данни като "привързване" към конкретно предаване, такива следва да се зареждат след зареждане на ТВ-програми (или едновременно с тях), в противен случай анонсите просто няма къде да бъдат записвани.

Наименования на канали в анонси и ТВ-програми могат да не съвпадат, или програмите на някои канали могат изобщо да липсват от файл с данни. В тези случаи ListTV ще направи опит да извърши търсене на програма (търсене се извършва по канал, дата и време за начало на предаване), като в случай на неуспех се издава съответно съобщение .

Внимание [image] Доколкото за обработка на файлове от различни сайтове се използват различни алгоритми, е желателно данните от всеки сайт да се зареждат отделно, като се избира съответен тип в диалога за зареждане. ListTV може да се опита автоматично да определи необходимост от нужен конвертор, но все пак съществува някаква вероятност за допускане на грешки. В случай на невъзможност за определяне на съответствие на файл с един от форматите се издава съобщение за неправилно избран конвертор и избраният файл не се зарежда.

  • Няма необходимост от запазване на обработени файлове - ListTV съхранява информацията в собствен файл с разширение .dat.

Програмата поддържа три вида зареждане на данни, параметри за които се задават в секция « Настройки ». Програмата автоматично обновява данните - извършва се проверка за срок на давност и се оставят само актуални ТВ-програми.

Алгоритъмът е следният: ако последната дата се намира в текущата седмица - остават данни за двете последни налични седмици, а всичко останало ще бъде премахнато. Всички данни, които са с по-стара дата от текущата седмица се съхраняват, но ще бъдат показвани само текуща седмица и следваща след нея, останалите данни ще се "проявят" по-късно - при настъпване на съответната дата.

  • Ако поща е постъпила в нарушен (не-цялостен) вид, спокойно могат да бъдат премахнати обработените файлове и да се добавят недостигащи такива по реда на тяхното постъпване. Наново зареждани данни се добавят към наличните.

При зареждане на нови данни и при зададена опция в прозорец «Канали» - [image] «Премахване на неотбелязаните», ненужни канали няма да бъдат включвани във файл с данни.

Допълнение: Ако се разполага с налична база данни с файлове във формат JTV (получена в готов вид или примерно вече създадена с ListTV и съхранена на определено място или на преносим носител), за да не се прибягва до нова обработка за друго работно място, на което е инсталирана ListTV и да се губи допълнително време, такава база може да бъде заредена директно от основния прозорец:

В следващия диалогов прозорец за зареждане може(гат) да бъде(ат) избран(и) необходим(и) файл(ове) или всички налични в базата,

при натискане на бутон [image] се извършва обновяване в ListTV.


Topic: Съобщения при зареждане на данни

List TV

Съобщения при зареждане на данни

Съобщения при зареждане на данни:

  • "Имя файла" : не удалось перекодировать текст.

    ("Име на файл" : неуспешно прекодиране на текст)

    Срив на програмата при прекодиране на текст. При появяване на такова съобщение да се потърси съдействие от автора на програмата (listlv@citycat.ru), като те посочи с какъв тип файл е работено.

  • "Имя файла" : неверно выбран конвертор.

    ("Име на файл" : неправилно избран конвертор)

    Необходимо е внимание при избор на тип файл в диалога за зареждане - за файлове от различни сайтове и абонаментно разпращане се използват индивидуални алгоритми за преобразуване, и за изключване на грешки при зареждане се проверява тип на файл по наличие на ключова дума.

  • "Имя файла" : новых данных не обнаружено.

    ("Име на файл" : не са намерени нови данни)

    Или се прави опит да се зареди файл, който не съдържа ТВ-програма, или датата на програмата във файла се различава от вече налична с повече от две седмици. Често такава грешка също така възниква при избор на неправилна кодировка при зареждане на файл.

Съобщения при зареждане на анонси:

  • "Имя файла" : анонсы не обнаружены.

    ("Име на файл" : не са намерени анонси)

    Или се прави опит да се зареди файл, който не съдържа анонси за ТВ-програма, или форматът на анонсите не съответства на използвания в ListTV.

  • Не найдена передача для занесения анонсов.

    (Не е намерено предаване за внасяне на анонси)

    Не съвпада времето за начало на предаване в ТВ-програма и в анонси.

  • Не найден день-канал для занесения анонсов.

    (Не е намерен ден-канал за внасяне на анонси)

    Не съвпада дата и наименование на канал за предаване в ТВ-програма и в анонси.

Показване на съобщения при зареждане на анонси може да бъде изключено, като се зададе отметка [image] «Да не се показват грешки в анонси» в диалоговия прозорец със съобщения.


Topic: Класификатор (типове) на предавания

List TV

Класификатор (типове) на предавания

В ListTV е предвидена възможност на предавания да се присвоява определен «тип» ( [image] филм, [image] сериал и т.н.) с цел по-удобно преглеждане на списък, филтрация или търсене. Това може да бъде направено по два начина:

  1. Ръчно - като на предаване се зададе необходим тип:

    клик с десния бутон на мишката по ред с избрано предаване,

    в контекстното меню се избира «Изменить тип», в подменюто се избира тип за предаване:

  2. Автоматично - чрез попълване на набор от двойка характерни за предаване ключови думи (фрази) - «Съдържа» и «Не съдържа» с указание за нужния тип.

    Ако в списъка с програми бъде намерено предаване, наименованието на което съдържа въведения текст, то ще бъде отделено с указания тип.

    Сканиране на списъка се извършва или при зареждане на нова ТВ-програма, или при изменение на списъка с ключови думи:

  • клик с десния бутон на мишката по ред с избрано предаване - в контекстното меню се избира опция [image] «Добавяне в класификатор...»

    Отваря се прозорец за въвеждане на двойки ключови думи (фрази) и тип на предаване, в който ще бъде копирано наименованието на предаване:

    «Тип на предаване» -

  • С помощта на прозорец «Настройки» [image] [image] за работа със списък от типове на предавания и настройки на списък с двойки ключови думи (фрази):

    Забележка: при въвеждане на набор от двойки ключови думи (фрази) могат да бъдат въвеждани няколко значения, като ключовите думи (фрази) се разделят със символ « ; ».

При преглед на списък с предавания в таблицата може да бъде включена филтрация по типове предавания с натискане на бутон [image]. При това се появява панел с бутони, с помощта на които може бързо да бъдат подбрани необходими предавания:

Работа с прозорец «Класификатор»: Прозорецът се състои от две части -

  • «списък на типове предавания», и

  • «списък на ключови думи (фрази)», които се използват за определяне на тип предаване. До задаване на ключови думи е необходимо да бъде създаден поне един тип предаване. По подразбиране в ListTV има известен набор от типове предавания и съответен набор от ключови думи, които могат да се променят по своя преценка. Превключване между списък с типове предавания и списък с ключови думи може да бъде осъществено при натискане на съответните бутони, или чрез съответните им клавишни еквиваленти «Ctrl+1» и «Ctrl+2».

  • Меню «Типове предавания» се характеризира със следните особености:

  • Наименование;

  • Изображение [2];

  • Указание за поместване на бутон в панела с филтри за типове предавания [1];

  • Указание за включване на даден тип предаване в текущия филтър, ако бутон е "невидим" [3].

Положението на ключова дума в списък определя реда за неговото използване. Проверка за наименование на предаване за принадлежност към някакъв тип предаване се извършва по целия списък, като се започва от първата дума - до пълно съвпадение. В съответствие с това, колкото по-нагоре в списъка се намира дадена дума , толкова по-голяма е вероятността да бъде използвана.

Положението на ключова дума, както и на тип предаване в списъка може да се променя чрез бутони [image] [image] .

Работа със списъци:

  • Въвеждане на нов типове предаване: Преминава се на страница «Типове предавания». Натиска се бутон [image] «Нов» [4] над списъка с типове предавания (клавишен еквивалент - "Ctrl+N").

    В диалоговия прозорец се въвежда наименование за тип на предаване, избира се изображение за този тип (файл във формат .bmp, размер 18x18 пиксела). Указва се дали е необходимо да се помества бутонът в панела с филтри за типове предавания и дали да се включва дадения тип на предаване в текущия филтър, ако бутонът е невидим. Натиска се бутон [image].

  • Въвеждане на нова (набор от) ключова(и) дума(и):

    Преминава се на страница «Ключови думи». Натиска се бутон [image] «Нов» [4] над списъка с ключови думи (клавишен еквивалент - «Ctrl+N»):

    В диалоговия прозорец - в реда на редактор «Съдържа» е необходимо да се въведе ключова дума (фраза), която трябва да бъде в наименованието на предаване. В реда на редактор «Не съдържа» - ключова дума (фраза), която не трябва да бъде в наименованието на предаване (или просто това поле се оставя празно. Думи (фрази) вътре в набора се разделят със символ « ; ».

    Натиска се бутон [image].

  • Поправки: За корекции на въведено съчетание е необходимо такова да бъде маркирано в списъка, да се натисне бутон [image] «Коригиране» [5] (Ctrl+E) и след нанасяне на изменения да се потвърди с бутон [image]. Извикване на прозорец за редактиране може да бъде осъществено също така с [image] [image] двоен клик с левия бутон на мишката по избран ред.

  • Премахване: За премахване на ключови думи (фрази) или типове предавания е необходимо такива да бъдат маркирани в списъка и да се натисне бутон [image] «Изтриване» [6] (Del)

  • Търсене в списък: Доколкото ключови думи в списък могат да бъдат достатъчно много, понякога да бъде намерена нужна такива е трудно. За улеснение на тази задача може да се използват следните методи:

  1. Подбор на думи за еднакъв тип предавания: В списъка с ключови думи, в колона "Тип" се натиска бутон «Филтър» [image] [8] (клавишен еквивалент - "F7") или се натиска черният триъгълник [image] [3] в дясната част на заглавието на колоната. Под заглавието на колона «Тип» ще се появи меню с всички типове предавания [image]...

    Избира се необходим тип, при което списъкът с думи ще бъде филтриран по този признак. За връщане към пълния списък повторно се натиска бутон «Филтър».

  2. Подбор на думи по наличие нужна част от дума ( [image] символен низ) в такива: В списъка с ключови думи - в колона «Съдържа» или «Не съдържа», се натиска бутон «Филтър» [image] [8] ("F7"), или се натиска върху троеточието [2] в дясната част на заглавието на колона. На мястото на заглавието на колона се появява прозорец за въвеждане на текст:

    По време на набиране на текст в същия, в списъка с думи ще остават само такива, които съдържат въвеждания текст. За връщане към пълния списък повторно се натиска бутон «Филтър».

  3. Подбор на думи по дата на премахване е аналогичен на т.2.

В долната част на прозореца се намира изключваем панел [1] с допълнителни настройки,

които се използват за повторно сканиране на файл с данни след изменения в списъка с ключови думи.

Всякакви изменения влизат в сила само след съхраняване (в зависимост от извършените действия, програмата напомня със съответни съобщения):

...

...

По отношение на файл с данни са приложими следните правила:

Ако е зададена опция «Потвърждаване веднага» ще се извършва сканиране при завършване на работа със списъка от типове предавания, в противен случай - само при зареждане на нова ТВ-програма.

Ако не е зададена опция «Да не се ползват ръчно установени типове» то предавания, тип на които е изменен ръчно няма да бъдат проверявани.

Забележки:

  • Търсене по ключови думи (фрази) в наименования на предавания не е чувствително към регистъра;

  • Наличие на празни полета (шпации) също се взима под внимание.


Topic: Рейтинги (Любими предавания)

List TV

Рейтинги (Любими предавания)

Любими предавания

В ListTV е предвидена възможност предавания да се маркират като «любими» (и не толкова «любими») с цел по-удобно преглеждане на списък, филтрация или търсене. Това може да бъде направено по два начина:

  1. Ръчно - като на предаване се зададе необходим рейтинг:

    клик с десния бутон на мишката по ред с избрано предаване:

    в контекстното меню се избира «Изменить рейтинг», в подменюто се избира тип за предаване:

  2. Автоматично - чрез попълване на набор от двойка ключови думи (фрази) «Съдържа» и «Не съдържа», характерни за предаване с указание за нужен рейтинг:

    Ако в списъка с програми бъде намерено предаване, наименованието на което съдържа въведения текст, то ще бъде маркирано с указания тип.

    Сканиране на списък се извършва или при зареждане на нова ТВ-програма, или при изменение на списъка с ключови думи:

  • клик с десния бутон на мишката по ред с избрано предаване - в контекстното меню се избира опция [image] =«Добавяне към "любими"...»

    Отваря се прозорец за въвеждане на двойки ключови думи (фрази) и рейтинг на предаване, в който ще бъде копирано наименованието на предаване:

    «Рейтинг» -

  • С помощта на прозорец «Настройки» [image] [image] за работа със списък от рейтинги на предавания и настройки на списък с двойки ключови думи (фрази):

    Забележка: при въвеждане на набор от двойки ключови думи (фрази) могат да бъдат въвеждани няколко значения, като ключовите думи (фрази) се разделят със символ « ; ».

При преглед на списък с предавания в таблицата може да бъде включена филтрация по рейтинг с натискане на бутони [image] или [image]. При това се появява панел с бутони, с помощта на които може бързо да бъдат подбрани необходими предавания:

Работа с прозорец «Любими предавания»:

Прозорецът за настройки на рейтинг се състои от две части:

  • «списък на рейтинги», и

  • «списък на ключови думи (фрази)», които се използват за определяне на тип предаване.

До момента на задаване на ключови думи е необходимо да бъде създаден поне един рейтинг. По подразбиране в ListTV има известен набор от рейтинги (без набор от ключови думи), които могат да се променят по своя преценка. Превключване между списък с рейтинги и списък с ключови думи може да бъде осъществено при натискане на съответните бутони, или чрез съответните им клавишни еквиваленти «Ctrl+1» и «Ctrl+2».

Меню «Рейтинги» се характеризира със следните особености:

  • Наименование;

  • Изображение [2];

  • Указание за поместване на бутон в панела с филтри за рейтинг на предавания [1];

  • Указание за включване на даден рейтинг в текущия филтър, ако бутон е "невидим" [3]:

Местоположението на рейтинг в списъка съответства на разположението на бутона в панела за рейтинг на предаване. По желание местоположението може да бъде променено (това не оказва влияние върху определянето на рейтинг) с помощта на бутони «Нагоре/Ctrl+Up» [image] или «Надолу/Ctrl+Down» [image] [7], или просто като се преместят маркирани редове в желаната позиция, като се задържа натиснат [image] левият бутон на мишката.

Ключова дума (фраза) се характеризира със следните признаци:

  • Признак за напомняне;

  • Рейтинг на предаване;

  • Набор от думи, които трябва да се съдържат в наименование на предаване;

  • Набор от думи, които не трябва да се съдържат в наименование на предаване;

  • Дата, след която ключова дума да бъде премахната.

    Ако не е зададена дата, ключова дума се използва постоянно!

Местоположението на ключова дума в списъка определя ред за нейното използване. Проверка за наименование на предаване за принадлежност към някакъв рейтинг се извършва по целия списък, като се започва от първата дума - до първо съвпадение. Съответно, колкото по-нагоре (по-високо) в списъка се намира дума, толкова по-голяма е вероятността от използване на същата. Местоположението на думи в списъка може да бъде променяно (това се отнася и за рейтингите на предавания):

Работа със списъци:

Въвеждане на нов рейтинг: Преминава се на страница «Рейтинги» [image] . Натиска се бутон [image] «Нов» [4] над списъка с рейтинги (клавишен еквивалент - «Ctrl+N»).

В диалоговия прозорец се въвежда наименование за рейтинг на предаване, избира се изображение за този рейтинг (файл във формат .bmp, размер 18x18 пиксела). Указва се дали е необходимо да се помества този бутон в панела с филтри за рейтинги на предавания и дали да се включва този рейтинг в текущия филтър, ако бутонът е невидим.

Натиска се бутон [image].

  • Въвеждане на нов набор от ключови думи: Преминава се на страница «Ключови думи». Натиска се бутон [image] «Нов» [4] над списъка с ключови думи (клавишен еквивалент - «Ctrl+N»).

    В диалоговия прозорец се въвежда наименованието на рейтинг за предаване, избира се изображение за този рейтинг. В реда на редактор «Не съдържа» - ключови думи (фрази), които не трябва да бъдат в наименованието на предаване (или просто това поле се оставя празно. Думи (фрази) вътре в набора се разделят със символ « ; ». Ако е необходимо се задава признак за напомняне.

    Натиска се бутон [image].

  • Поправки: За корекции на въведено съчетание е необходимо такова да бъде маркирано в списъка, да се натисне бутон [image] «Коригиране» [5] (Ctrl+E) и след нанасяне на изменения да се потвърди с бутон [image]. Извикване на прозорец за редактиране може да бъде осъществено също така с [image] [image] двоен клик с левия бутон на мишката по избран ред.

  • Премахване: За премахване на ключови думи (фрази) или типове предавания е необходимо такива да бъдат маркирани в списъка и да се натисне бутон [image] "Изтриване" [6] (Del).

  • Търсене в списък: Доколкото ключови думи в списък могат да бъдат достатъчно много, понякога да бъде намерена нужна такива е трудно. За улеснение на тази задача може да се използват следните методи:

  1. Подбор на думи за еднакъв рейтинг на предаване: В списъка с ключови думи [image], в колона "Рейтинг" се натиска бутон "Филтър" [image] [8] (клавишен еквивалент - "F7") или се натиска черният триъгълник [3] в дясната част на заглавието на колоната:

    Под заглавието на колона "Рейтинг" ще се появи меню с всички рейтинги за предавания

    ...

    Избира се необходим рейтинг - списъкът с думи ще бъде филтриран по този признак. За връщане към пълния списък повторно се натиска бутон "Филтър".

  2. Подбор на думи по наличие нужна част от дума ( [image] символен низ) в такива: В списъка с ключови думи - в колона "Съдържа" или "Не съдържа", се натиска бутон «Филтър» [image] [8] ("F7"), или се натиска върху троеточието [2] в дясната част на заглавието на колона. На мястото на заглавието на колона се появява прозорец за въвеждане на текст:

    По време на набиране на текст в същия, в списъка с думи ще остават само такива, които съдържат въвеждания текст. За връщане към пълния списък повторно се натиска бутон «Филтър».

  3. Подбор на думи по дата на премахване е аналогичен на т.2.

В долната част на прозорец «Допълнителни настройки» [image] се намира изключваем панел [1] с допълнителни настройки

,

които се използват за повторно сканиране на файл с данни след изменения в списъка с ключови думи.

Всякакви изменения влизат в сила само след съхраняване:

По отношение на файл с данни са приложими следните правила:

Ако е зададена опция «Потвърди веднага» ще се извършва сканиране при завършване на работа със списъка от типове предавания, в противен случай - само при зареждане на нова ТВ-програма.

Ако не е зададена опция «Не ползвай ръчно установените рейтинги» то предавания, рейтинг на които е изменен ръчно няма да бъдат проверявани.

Забележки:

  • Търсене по ключови думи (фрази) в наименования на предавания не е чувствително към регистъра;

  • Наличие на празни полета (шпации) също се взима под внимание.

Предавания, които съответстват на ключови думи със зададен признак за напомняне автоматично се включват в списък за напомняне. В зависимост от опциите, зададени в раздел «Настройки» - [image] - [image] «Напомняне»,

напомняне може да бъде съпроводено от звуков сигнал и може да сработва няколко минути преди началото на предаване.


Topic: Настройки на канали

List TV

Настройки на канали

На този етап програмата поддържа около 200 канала, които могат да бъдат управлявани по-лесно чрез прозорец «Канали».

Прозорецът се състои от две страници:

  • «списък на канали» със съответните им свойства;

  • «допълнителни настройки» (общи за всички канали).

    Превключване между тези страници се осъществява с помощта на съответните бутони или с "горещи" клавиши (Ctrl+1/Ctrl+2).

Как се работи с канали?

  • Ръчно добавяне на канали не е необходимо. Канали се отделят автоматично от зареждана програма с предавания и се поместват в списък, в който могат да бъдат променяни техните свойства.

  • За да бъдат направени канали "невидими", т.е. за да не се използват при извеждане на информация, е необходимо само да бъде свалена съответната отметка чрез [image] клик с левия бутон на мишката в "чекбокс" [image] в ляво от наименование на канал (или да се натисне клавиш "интервал" ("шпация"), като се маркира необходим ред). Ако е нужно да бъдат премахнати напълно данни за невидими канали се задава опция «Премахване на неотбелязаните» в превключвателя на страницата за общи настройки. При това програмата ще се зарежда по-бързо, т.к. се намалява размерът на файла, с който същата работи.

Забележки:

  • Списъкът с канали поддържа сортиране по колони (необходимо е да се натисне върху заглавието на съответна колона с курсора на мишката; при повторно натискане - сортиране в обратен порядък).

  • При зареждане на нови данни и зададена опция «Премахване на неотбелязаните», ненужни канали няма да бъдат включвани във файл с данни.

  • Корекции: За преход в режим за корекции е необходимо да се маркира канал от списъка и да се натисне бутон «Коригиране» [image] («Ctrl+E»)

За да влязат в сила направени изменения е необходимо потвърждаване с бутон [image]. Извикване на прозорец за редактиране е възможно чрез [image] [image] двоен клик с левия бутон на мишката по избран ред, клавишен еквивалент - «Ctrl+E».

В режим на корекции е възможно:

а) изменение на номер на канал;

б) въвеждане на алтернативно наименование (синоним) за канал, което да се използва в програмата;

в) избиране на емблема за канал;

г) задаван на индивидуално изместване по време за канал.

Забележка:

Свойства на канал са достъпни също така в главния прозорец при извикване на контекстното меню в "дървото" с дни/канали или в списъка с предавания.

  • Премахване:

    За премахване на канал е необходимо такъв да бъде маркиран в списъка и да се натисне бутон [image] (Del). Премахване на канал трябва да се прави само в случай, че това е в резултат на грешка при зареждане, или че програмите на този канал повече никога няма да бъдат в зареждана ТВ-програма. В противен случай при следващо зареждане на ТВ-програма каналът отново ще се появи в списъка.

    Ако е необходимо да бъдат премахнати предавания от ненужни канали може да се използва настройка [image] «Изтриване на предаване» от група [image].

Забележка: Програмата е достатъчно "интелигентна" и при предприемане на действия, последиците от които се отразяват на по-нататъшното й функциониране издава предупредителни съобщения в съответствие с направени изменения, например:

Общи настройки:

  • Група [image]:

    при зададена опция «Да не се показват» данните за неотбелязани канали се съхраняват във файл и "невидими" канали могат да бъдат показани в таблиците във всеки момент. В противен случай -

    «Изтриване на предаване» - данните се премахват.

  • («Сдвинуть время передач...») - стойности за изместване по време, зададени в този раздел [image] се прилагат към всички канали, за които не са зададени индивидуални параметри в режим на корекции. При изменение на стойност за изместване по време, това автоматично се изобразява и в списъка с канали. Ако в процеса на изменение стойността за изместване се сравнява с една от индивидуално зададените стойности, по-нататък този индивидуално зададен параметър ще бъде прието за равно на стойността в общите настройки и ще се променя съвместно със същата.

    «Прилагане на изместване по време» има две възможности:

    «Незабавно» - времето на предаване за канали, при които е било изменено изместване по време ще бъде поправено веднага; в противен случай -

    «При следващо зареждане на данни» - само при зареждане на нови данни.

  • Забележка:

    Програмата не определя автоматично часови пояс, в който се намира даден потребител - часова разлика е необходимо да се зададе ръчно.

Всякакви изменения влизат в сила само след съхраняване («Ctrl+S»).


Topic: Настройки на анонси

List TV

Настройки на анонси

Зареждане на анонси: Програмата поддържа анонси

  • от "Кулички" ( http://tv.kulichki.net/ );

  • от "TVin.Net.Ru" (Москва) ( http://tvin.net.ru/ ).

Как се зареждат: Файл с анонси за ТВ-програми се зарежда като обикновена програма (напомняне: при зареждане да се избере съответен тип файл - сайт, от който се взимат анонси).

Как се използват: Анонси в програмата се пазят само като свързани към конкретно предаване, т.е. при зареждане на анонси се извършва търсене на анонсирано предаване; ако такова не бъде намерено информацията просто се игнорира, а на потребителите се излъчва съответно съобщение.

Преглеждане на анонси е възможно при маркиране на предаване в списъка. Ако е зададена съответната опция, под основния прозорец ще се отвори малък подпрозорец, в който се извежда информацията.

Как се работи с «Настройки на анонси»: Настройка на анонси представлява

  • избор на списък с канали, в които ще се извършва търсене на необходимо предаване -

    § маркира се канал с анонси в списъка;

    § натиска се бутон «Коригиране» или съответен команден ред от контекстното меню (достъпно е при натискане на [image] десния бутон на мишката върху списъка) със същото наименование;

    § отваря се допълнителен прозорец със списък на синонимни канали, които се използват в програмата;

    § отмята се [image] необходим канал в "чекбокс"-а в ляво от синоним на канал;

    § затваря се прозорецът.

  • задаване на изместване по време в предавания в текст на анонси:

    Доколкото търсене на анонсирани предавания се извършва по дата, време и наименование на канал, задаване на правилно изместване по време е особено важен параметър. Задаване на изместване може да бъде направено едновременно за всички канали с анонси (чрез използване на редактора под списъка с канали) или за всеки канал поотделно, като се извика прозорецът за редактиране с бутон [image] «Коригиране».

  • Избор на собствен канал с анонси, който да се използва в програмата по желание -

    състои се задаване на отметка [image] в "чекбокс"-а в ляво от наименование на канал с анонси. Това е сигнал за използване на такъв канал. Трябва да се има предвид, че ако е зададена отметка, а списъкът със синоними не е запълнен, при всяко зареждане на анонси програмата ще спира, като изисква настройки за синоними. Ако това е дразнещо - да се премахне отметката.

За какво се използва бутон «Изтриване» [image] : При зареждане на анонси са възможни сривове, като при неправилно определяне на наименование на канал вместо него може да бъде записан различен вид "отпадъчна" информация. С помощта на този бутон това може да бъде избегнато. Истински канали с анонси трябва да бъдат премахвани само, ако повече не се предвижда да бъдат зареждани. В противен случай, дори да не се предвижда такива да бъдат използвани, при следващо зареждане тези канали могат да се появят отново в списъка.

Опция «Да не се показват грешки в анонсите» (меню [image] «Допълнителни настройки»):

За всяко не намерено предаване ListTV съобщава на потребителя, което понякога просто омръзва, т.к. на практика нищо не може да бъде поправено (ако изобщо е нямало такъв канал или ден от седмицата, за които програмата съобщава), или не е желателно (дори само поради мързел). При използване на тази настройка такива съобщения могат да бъдат игнорирани.

Допълнително:

"Горещи" клавиши -

  • Коригиране («Коригирай»): «Cttl+E».

  • Премахване («Изтрий»): «Del».

Общи настройки -

  • «Изместване на предавания по време» - величината за изместване по време, зададена в този раздел се прилага към всички канали, за които не са зададени индивидуални величини в режим на корекции. При промяна на величината на изместване, това автоматично се изобразява и в списъка на канали-анонси. Ако в процеса на изменение величината на изместване се сравнява с едно от индивидуално зададените стойности, по-нататък тази индивидуално зададена стойност ще бъде приета за равна на стойност в общите настройки и ще се променя съвместно с тях.

  • Забележка:

    Програмата не определя автоматично часови пояс, в който се намира даден потребител - часова разлика е необходимо да се зададе ръчно.

  • Добавяне на нови канали в списък става автоматично при обработката на информация;

  • Списъкът с канали поддържа сортиране по колони (клик върху заглавие на колона с курсора на мишката; при повторно натискане се извършва сортиране в обратен порядък).

Всякакви изменения влизат в сила само след съхраняване («Ctrl+S»).


Topic: Настройки на тунер

List TV

Настройки на тунер

Управление на ТВ-тунер е възможно само за софтуерни програми на тунери, които поддържат превключване на канали с цифрови клавиши. В ListTV това е реализирано в минимален обем:

  • стартиране на програмата, ако не е пусната (необходимо е да се укаже път към изпълним файл) -

  • превключване на тунера с двоен клик по реда с програма на предавания, на канал за избрано предаване (за всеки канал е необходимо в прозорец «Настройки на канали» да се укаже неговия номер, съответстващ на номер в програмата на ТВ-тунера);

    Ако се използва ПО за тунер BeholdTV или Fly2000TV трябва да се избере съответен ред от "падащия" списък:

    в противен случай се избира ред «Стандартни настройки».

  • За BeholdTV не е необходимо да се настройва нищо повече (освен може би закъснение между превключване на канали).

    По-долу е описан ред за настройки за всички други тунери с изключение на BeholdTV:

Управление се осъществява чрез изпращане на управляващи кодове към прозореца на програмата на тунера. За да бъде това възможно е необходимо този прозорец да бъде определен. Редът за действия е следният:

  • стартира се програмата та тунера (ако това не е направено);

  • натиска се бутон [image];

  • кликва се с курсора на мишката в прозореца на програмата на тунера;

В резултат трябва да се попълнят две величини - «Наименование на прозорец» («Заголовок окна») и «Клас на прозорец» («Класс окна»). По тези параметри ListTV ще извърши търсене прозорец на програмата на тунера за изпращане на съобщения. Могат да бъдат използвани както двата параметъра, така и всеки от тях поотделно. Необходимост от използване на параметрите се определя от конкретните програми на тунерите.

Така например, за AVerTV Studio се препоръчва да се използва само наименование на прозорец, т.к. клас на прозорец се променя при всяко отделно стартиране.

  • Допълнителни настройки:

    Доколкото съществуват множество най-различни програми за работа с тунери, всяка от които има свои индивидуални особености, са въведени допълнителни настройки. За съжаление няма статистика за резултатите от използването на същите, поради което се налага това да се проверява самостоятелно. Това може да бъде направено и от прозореца за настройки на тунер.

За AVerTV Studio се препоръчва да се използват следните настройки:

The contents of Настройки на тунер

Behold TV


Topic: Behold TV

List TV

Behold TV

Използване на ListTV с Behold TV

Визуална илюстрация на отлични резултати при работа с ListTV може да бъде направена посредством осъществяване на връзка с програмния комплекс Behold TV:

В Behold TV са интегрирани модули « Програма с предавания » и «Модул за планирани задачи», успешна автоматизирана работа с които в известна степен зависи от наличието на достъпна база данни във формат JTV.

Доколкото преди и по време на работата върху настоящия материал в интернет-пространството на практика не бяха намерени никакви такива бази на български език (дори с помощта на "чичко Гуугъл..."), с ListTV създаване на подходяща база отнема броени минути. Конкретните стъпки са елементарни и са описани подробно в раздел « Експортиране ». Останалото е въпрос на няколко клика с мишка...

The contents of Behold TV

Модул «Програма с предавания»


Topic: Модул «Програма с предавания»

List TV

Модул «Програма с предавания»

Модул «Програма с предавания»

В Behold TV - модул «Програма с предавания», секция «Настройки» се задава папка, в която да се търси база данни във формат JTV (при инсталиране на Behold TV по подразбиране е зададена C:\Beholder\TVGuide):

  • Ако в диалоговия прозорец за настройки на параметри за съхранение на файл в ListTV е зададена (се зададе) същото местоположение, е необходим [image] само един клик за да бъде извършено експортиране [image].

  • Правилно експортирана база данни незабавно се визуализира в Behold TV

    при което стават достъпни ред удобни "екстри":

    При смяна на канал в долната част на основния видеопрозорец автоматично се изобразява OSD блок със сбита, но подробна информация за:

  • номер и наименование на канал с текущо предаване;

  • текущо време, процент на изминало време от началото на предаване;

  • наименование на текущо предаване;

  • цифрова и графична информация за начало и край на предаване.

При необходимост такова показване може да бъде изведено отново или да се покаже следващо или предишно предаване (вж. настройки на клавиши за управление в BeholdTV).

Програма с предавания в BeholdTV може да бъде извикана на екран от едноименните редове в контекстните менюта за управление на основния видеопрозорец или на иконката на Behold TV в трея ( [image] десен клик във видеопрозореца или върху иконката), при което към списъка с канали се добавя кратка информация за наименование и процент от изминало време от предавания:

...


Topic: Допълнителна информация

List TV

Допълнителна информация

Допълнителна информация

The contents of Допълнителна информация

«Горещи» клавиши
Зареждане на данни
Често задавани въпроси


Topic: «Горещи» клавиши

List TV

«Горещи» клавиши

"Горещи" клавиши (Клавишни комбинации) в главния прозорец


Topic: Зареждане на данни

List TV

Зареждане на данни

Съобщения при зареждане на данни


Topic: Често задавани въпроси

List TV

Често задавани въпроси

(F.A.Q.)

  1. В: Анти-вирусната програма (AVP) намира вирус в инсталационния файл на програмата?

    О: Няма никакъв "вирус". Това е вид "неадекватна" реакция на AVP спрямо инсталатор Createlnstall ( http://www.gentee.com ). Ако това все пак е повод за безпокойство - на сайта на ListTV има архив без инсталатор.

  2. В: Къде в програмата се намира корекция по време за различни часови пояси?

    О: В прозорец " Канали ".

  3. В: Как да се обновяват данни?

    О: ListTV не зарежда ТВ-програми от Интернет, а само използва файлове, получени индивидуално от потребителите (по поща или свалени от сайт). Самият процес е подробно описан в раздел зареждане на данни .

  4. В: Как да се разполагат канали в желан ред?

    О: Да се зададат на каналите съответни номера.

  5. В: Защо в прозорец "Канали" не могат да се поставят/премахват отметки?

    О: Най-вероятно трябва да бъде обновен файл comctl32.dll, който влиза дистрибутива на Windows.

  6. В: От къде да се намери нова версия на comctl32.dll?

    О: Microsoft предоставя за зареждане специален update, който инсталира нова версия на comctl32.dll. Линк за сваляне: http://download.microsoft.com/msdownload/iе401/patch/comcontrol/en/401comupd.ехе

  7. В: Може ли да ми бъде изпратена нова версия на вашата програма?

    О: Не съм в състояние да изпращам програмата на всички желаещи, дори ако е платена:).

  8. В: Как може да се разбере за излизане на следващи версии?

    О: Сведения за програмата редовно се обновяват на основните мрежови сървъри. Достатъчно е "абониране" в някой абонаментен списък в тези сайтове! Информация може също така да се получава лично от разработчика, за което е необходим абонамент на страницата за download на програмата - http://www.citycat.ru/tv/ListTV/dload.html .

  9. В: Откъде да се намери програма за канал ххх...?

    О: Известни за момента места в Интернет са изброени в раздел "Телемания" ( http://www.citycat.ru/tv/TVinNet/ ). Ако има информация за други адреси - пишете.

  10. В: Може ли в ListTV да бъде направена поддръжка на формат за програми от сайта (абонаментна поща) ххх...?

    О: Може, разбира се! ListTV достатъчно лесно се настройва към формат на произволен сайт (абонамент). За целта обаче е необходимо да се кореспондира не само с автора на ListTV, но и със собствениците на сайтове (абонаменти), чиито програми са необходими. Доколкото програмата е безплатна е достатъчно поместване на препратка към сайта на ListTV, поместена на сайта на съответните програми (абонаменти).

  11. В: Може ли самостоятелно да се подготвят за зареждане в ListTV програми от ТВ-сайт, чийто формат не се поддържа от ListTV? В какъв формат е файл ListTV.dat?

    О: Разбира се, може. За това не е задължително да се знае форматът на файл ListTV.dat (още повече, че същият понякога се променя). За подготовка на текст с ТВ-програма за зареждане, формат на такъв може да бъде насочен за абонамент към "Городской Кот" съгласно следните правила:

    За ТВ-програма на базата на "Городской Кот":

    Форматът на входния файл трябва да отговаря на следните условия:

    - в текста на програма (желателно в първите редове) трябва да присъства ключова дума, която еднозначно идентифицира източника на програма (за "Городской Кот": "tv.all"). Това е свързано с причината, че за различните сайтове се използват различни алгоритми за разпознаване.

    - текстът на програма трябва ясно да се подразделя на блокове "дата-канал-предаване". Т.е. като разделител между блоковете се явява дата до наименование на канал. В следващите редове са предавания. ListTV по наличие на дата определя началото на нов блок и край на предходен. Форматът за дата не е от голямо значение. (Пример - за "Городской Кот": Понеделник. 22 март. OPT (може без "понеделник" и без точка"."))

    - допуска се до първата дата да има поместен информационен блок (например реклама или обява) - този блок се игнорира от ListTV.

    - допуска се поместване на информационен блок след последния блок на ТВ-програми. В този случай отсечка става по ключова дума, която се явява идентификатор за начало на този инф. блок (например "Реклама") - този блок се игнорира от ListTV.

    По-подробно:

    В първия ред на файл се допълва "tv.all", по-нататък се помества информация по блокове:

    2-ри ред: Ден от седмицата. Дата. Наименование на канал

    3-ти ред: време във формат чч:мм, празно (шпация), Наименование на предаване

    4-ти ред: време във формат чч:мм, празно (шпация), Наименование на предаване

    n-ти ред: време във формат чч:мм, празно (шпация), Наименование на предаване

    празен ред

    и т.н.

    Дата във формат ДД месец. (Пример: 24 май). При зареждане да се укаже тип на файл: "Городской Кот". Останалото програмата ще извърши самостоятелно, т.е. ще намери всички нови канали и ще позволи да се редактират ТВ-програми по собствено желание.

    За формиране на собствени анонси е по-добре да се използват настройки, както в "Кулички" ( http://tv.kulichki.net ):

    всички правила за оформяне са същите, както и за предавания, но преди наименование на канал да се добави "(Анонс)". Ключова дума за "Кулички" е "andgon".

  12. В: Не се зарежда файл с програми?

    О: Първо, да се провери правилно ли е избрано кодиране при зареждане;

    второ - да е сигурно, че файл е взет от сайт, който официално се поддържа от ListTV.

    Ако тези условия са изпълнени правилно - изпратете този файл, заедно с индивидуалния файл LisITV.ini;

  13. В: Как е написана програмата?

    О: Delphi 3.

  14. В: Предоставя ли се изходният код?

    О: Не. Ако има някакви конкретни въпроси по програмиране - питайте автора, "ако може - ще отговори"...

    ...

The contents of Често задавани въпроси

Информация за формат JTV


Topic: Информация за формат JTV

List TV

Информация за формат JTV

Информация за формат JTV

Цит. PcTuner.Ru Форум / Общая тематика и компьютеры / Программирование / Описание формата JTV

...Описание на формат за ТВ-програми JTV:

Генератор на С++:

// Written by Dmitry <a7051999@mail.ru>

//

#include <fcntl.h>

#include <io.h>

#include <stdio.h>

#include <windows.h>

#include <sys/stat.h>

#define error(test,str) if(test){printf(str);return 1;}

int main(int argc, char* argv[])

{

FILETIME ft;

SYSTEMTIME st;

FILE *f1;

int f2,f3;

char name[5000];

printf("JTV 3.0 TVGuide generator v3 by Dmitry <a7051999@mail.ru>\n");

error(argc<2,"Usage: guidegen.exe filename_without_extension [/extract]\n");

char sf1[100];sprintf(sf1,"%s.txt",argv[1]);

char sf2[100];sprintf(sf2,"%s.ndx",argv[1]);

char sf3[100];sprintf(sf3,"%s.pdt",argv[1]);

if(argc==2){

f1=fopen(sf1,"rt");error(!f1,"Can't open file .txt!\n");

f2=open(sf2,O_RDWR|O_BINARY|O_CREAT|O_TRUNC,_S_IWRITE|_S_IREAD);

f3=open(sf3,O_RDWR|O_BINARY|O_CREAT|O_TRUNC,_S_IWRITE|_S_IREAD);

error(f2<0 || f3<0,"Can't open file .ndx or .pdt!\n");

int nelem=0;

error(write(f2,&nelem,2)<0,"Write error!\n");

char jtvsgn[]="JTV 3.x TV Program Data\x0a\x0a\x0a";

error(write(f3,jtvsgn,26)<0,"Write error!\n");

int offset=0x1a;

while(7==

fscanf(f1,"%hd %hd %hd %hd %hd %hd %[^\n]",

&st.wDay,

&st.wMonth,

&st.wYear,

&st.wHour,

&st.wMinute,

&st.wDayOfWeek,

name

)){

st.wSecond=0;

st.wMilliseconds=0;

SystemTimeToFileTime(&st,&ft);

int tmp=0;

write(f2,&tmp,2);

write(f2,&ft,8);

write(f2,&offset,2);

int len=strlen(name);

write(f3,&len,2);

write(f3,name,len);

offset+=len+2;

nelem++;

}

lseek(f2,0,SEEK_SET);

write(f2,&nelem,2);

printf(".ndx and .pdt files created success.\n");

}else{

error(stricmp(argv[2],"/extract"),"Incorrect option!\n");

f1=fopen(sf1,"wt");error(!f1,"Can't open file .txt!\n");

f2=open(sf2,_O_RDONLY|O_BINARY);

f3=open(sf3,_O_RDONLY|O_BINARY);

error(f2<0 || f3<0,"Can't open file .ndx or .pdt!\n");

int nelem=0;

error(read(f2,&nelem,2)<0,"Read error!\n");

for(int i=0;i<nelem;i++){

int tmp;

read(f2,&tmp,2);

read(f2,&ft,8);

FileTimeToSystemTime(&ft,&st);

fprintf(f1,"%d %d %d %d %d %d\n",

st.wDay,

st.wMonth,

st.wYear,

st.wHour,

st.wMinute,

st.wDayOfWeek?st.wDayOfWeek:7

);

long offset=0;

read(f2,&offset,2);

lseek(f3,offset,SEEK_SET);

int len=0;

read(f3,&len,2);

read(f3,name,len);name[len]=0;

fprintf(f1,"%s\n",name);

}

printf(".txt file created success.\n");

}

fclose(f1);

close(f2);

close(f3);

return 0;

}

1. Описание на формата?

2. Изглежда, че само в славянския свят се разпространяват програми във формат JTV. "Западните" програми поддържат често само XMLTV:

2.1. Защо не се поддържа в XMLTV Руски?. Форматът е по-удобен спрямо JTV?

2.2. Защо просто няма генератори във формат за файлове XMLTV.

2.3. Защо родните програми не поддържат формат XMLTV.

P.S. Ако някой е изучавал XMLTV да сподели дали този формат има по-богати възможности спрямо JTV.

...Погледни TVXB (www.tvxb.com) и TVGuru (www.tvguru.ru). И двете експортират в XMLTV

...Оказва се, че във вътрешната структура на бази данни в JTV няма нищо сложно:-)

Линк:

<http://www.pctuner.ru/go.php?url=1d3d3LnR2Z3VydS5ydS9jZ2ktYmluL2ZvcnVtLnBsP3RvcGljPTMz>

В архива има http-линк

<http://www.pctuner.ru/go.php?url=1anR2aG9zdC5jaGF0LnJ1L2ZpbGVzL2d1aWRlZ2VuLnppcA==>

Изходен ключ за С++, с помощта на който Oleg Antoshkiv дава обяснения:

PDT:

В началото на файл винаги се намира текст "JTV 3.x TV Program Data"

След него са три символа с код 0Ah, след което, като се започне с изместване 01Ah се повтарят записи с променлива дължина:

* 2 байта за количество символи в наименоване

* Hаименоване та ТВ-програма

NDX:

Първите два байта във файл са количество записи,

Следват записи, всеки от които е с размер 12 байта:

* първите 2 байта в запис винаги са равни на 0

* осем байта структура FILETIME (дата и време аз начало на ТВ-програма)

* два байта - изместване-указател във файл PDT за количество символи в наименование на ТВ-програма.

Описание на структура FILETIME не можах да намеря, вероятно това са количество секунди, като се започне от някоя дата, но може просто да се конвертира тази структура в SYSTEMTIME с функция FileTimeToSystemTime и обратно с функция SystemTimeToFileTime (Win32 API).

The FILETIME structure is a 64-bit value representing the number of 100-nanosecond intervals since January 1, 1601.

typedef struct _FILETIME { // ft

DWORD dwLowDateTime;

DWORD dwHighDateTime;

} FILETIME;

Members

dwLowDateTime

Specifies the low-order 32 bits of the file time.

dwHighDateTime

Specifies the high-order 32 bits of the file time.

Remarks

It is not recommended that you add and subtract values from the FILETIME

structure to obtain relative times. Instead, you should

* Copy the resulting FILETIME structure to a LARGE_INTEGER structure.

* Use normal 64-bit arithmetic on the LARGE_INTEGER value.

<http://www.pctuner.ru/go.php?url=1d3d3LnBpY2xpc3QuY29tL3RlY2hyZWYvb3Mvd2luL2FwaS93aW4zMi9zdHJ1Yy9zcmMvc3RyMDdfMjQuaHRt>

...Не мога да намеря в този формат наименования на канали?

Предвижда ли се от формата такава логическа функционалност?

/добавено/ Няма никакви наименования. Само ако име на файл може да съдържа наименование, но това е по осмотрение на този, който генерира тези файлове.

Copyright © 1999-2010 PcTuner.Ru <http://www.pctuner.ru>


Topic: Обновяване и обратна връзка

List TV

Обновяване и обратна връзка

Обновяване и обратна връзка

The contents of Обновяване и обратна връзка

Обновяване
Обратна връзка


Topic: Обновяване

List TV

Обновяване

Обновяване

  • Адрес за сваляне на нови версии, информация за новини за програмата - домашна страница на ListTV: http://vwwv.citycat.ru/tv/ListTV/

    На същия адрес може да бъде намерена голяма колекция от препратки към сайтове с ТВ-програми и друга полезна информация.

  • За получаване на анонси за нови версии на програмата чрез Subscribe.Ru може да се ползва форма за абонамент на сайта на ListTV на страница: http://vwwv.citycat.ru/tv/ListTV/dload .html


Topic: Обратна връзка

List TV

Обратна връзка

Обратна връзка:

По всички възникнали въпроси, както и за предложения и съобщения за грешки се обръщайте към автора на програмата - Евгений Юриевич Сверчков на адреси: listtv@citycat.ru или 2:5031/12.23

Настоятелна молба:

  • Преди да се отправя въпрос, да се погледнат поне първите раздели на помощната информация и " Често задавани въпроси ";

  • Преди да се съобщава за грешки в програмата да се провери, дали се работи с последната версия -

  • Възможно е Вашите пожелания да са вече внедрени, а грешките - поправени.

  • При съобщаване за грешки да се подава информация за:

    - версия на ListTV, която се използва;

    - версия на Windows;

    - сайт с програма на предавания, който се използва;

    - възможно най-подробно описание на възникналия проблем, желателно - всички потребителски действия до възникването на проблем или грешка.

Информация за контакти:

Официален сайт:

http://www.citycat.ru/tv/ListTV/

Страница за поддръжка/download:

http://www.citycat.ru/tv/ListTV/dload.html

Форум/FAQ:

http://www.citycat.ru/~jumper/

E-mail:

listtv@citycat.ru

Регионална информация :


Topic: Българска редакция

List TV

Българска редакция

Някои особености в българската редакция ( thebest@mail.bg ) на материалите

Бележки по превода и редактирането

  • Структуриране на материалите

  1. При превода на интерфейса, помощни инструкции и др. материали по правило са полагани усилия да се следват стриктно постройките на оригиналните текстове и структура с цел избягване на смислови и/или терминологични неточности и при необходимост - предоставяне на възможности за по-лесно сравнение с основните източници.

  2. При писането на материала за ListTV като първоизточник е ползван вграденият български интерфейс във версия [image], превод Георги Г. Милев .

    По преценка на автора на настоящата Help-версия, в интерфейса и ресурсния езиков файл са направени някои изменения. Това е свързано основно с някои общи правила за изразяване (писане, оформление) и лични предпочитания при редактирането, както и във връзка с намерени (несъществени) граматически пропуски и принципно не засяга функционалните характеристики на програмата.

    Така например, използваното в оригиналния интерфейс повелително наклонение - запиши, изтрий, коригирай... и пр. (демек, "ти ли пък ще ми кажеш какво да правя?!!") е заменено с неопределено - запис, изтриване, коригиране... и пр.

    Това по никакъв начин не налага ограничения върху личните предпочитания на отделните потребители и може да бъде променено във всеки момент по собствено желание, както е описано в този подраздел.

  3. Някои относително самостоятелни части в рамките на дадени раздели са допълнително отделени в подраздели с цел обособяване на конкретна терминология, например:

    при което общи особености са оставени в основния раздел, а специфични настройки са структурирани в съответни подраздели.

    Пълно (разширено) съдържание на инструкцията е посочено в края.

  • 4 Стилово оформление

    *За ориентиране в промените на софтуера, в българската редакция са използвани различни цветове на шрифт:

  • авторски коментари, забележки и допълнения/пояснения са в сиво-син цвят,

  • препоръчителни величини, настройки и пр. са подчертани в зелен цвят,

  • забележки, предупреждения [image] , напомняне [image] и други важни моменти са в червено.

    При превода беше забелязано, че части от терминологията принадлежат смислово към отделни групи и е възможно относително обособяване по такъв признак.

    Такива например са различни абзаци (изречения, таблици и пр.) за

    настройки и технически параметри/величини,

    теоретични понятия/термини и пр.

    При стиловото оформление в българската редакция пред такава терминология допълнително са използвани символи (Wingdings) или мини-иконки, с които да бъде "подсказано" за какво става въпрос в следващи текстове.

    Таблица с пояснения на използвани символи е поместена тук .

  • Терминология; [image] речник - общи бележки**

    **Речници на използвани термини и съкращения са поместени тук .

  1. При превода и редактирането някои термини (най-вече свързани с менюта на програми, опции и съобщения на операционната система) са възстановени от руски на английски език (без да се превеждат на български език). Това е направено умишлено при редактирането – лично мнение на редактора е, че в ХХІ век не е уместно да се превеждат специфични термини (от сорта на „Recycle Bin” > „Кошче за отпадъци” и пр.), с които масовият потребител би трябвало да борави свободно. Такива термини са представени в курсив (Italic) и са оцветени в тъмно син цвят.

  2. Някои по-специфични термини и текстове (при превода на които е възникнало съмнение за коректните термини на български език или е необходимо последващо доуточняване и/или редактиране) са оставени непреведени. Такива текстове/термини са оцветени в „orange”. При всяка следваща редакция се полагат усилия проблеми от такъв характер да бъдат окончателно уточнени и преведени (или обяснени), доколкото това е по възможностите на автора/редакцията.

  3. Трябва да се има предвид, че при различните версии на операционната система (съкр. "ОС", "OS") някои системни екрани, падащи менюта, прозорци, команди за изпълнение и пр. имат различен интерфейс и транскрипция в сравнение с описаните такива по-долу. Примерите и екранни снимки (screen shots) в материалите са изведени при инсталиране и тестване на драйвери и основна програма на базата на сравнително широко разпространената ОС Windows XP (SP2) в англоезичен вариант.

  4. Преводът на български език на оригинални менюта, подменюта, команди, съобщения, опции и пр. в прозорци/подпрозорци на оригиналния рускоезичен интерфейс са в курсив и тъмно син цвят.

  5. При всяка възможност са правени екранни снимки от българския интерфейс на програмата при тестване в реално време върху следната конфигурация:

    Софтуер - Behold TV v.5.15; драйвер v.5.3.0.0;

    Хардуерен модул – хибриден тунер Behold TV H6 с чипсет SAA7135 и "традиционен" ВЧ-модул МК3.

The contents of Българска редакция

Символи и съкращения
Речник
Системна информация
За контакти / Полезни връзки


Topic: Символи и съкращения

List TV

Символи и съкращения

Често използвани символи (разделители)

Символ | Значение, пояснение:
(б. а.) (доп. р.) | Бележки/допълнения от автора на превода / редакцията (извън рамките на оригиналните текстове). Шрифт: в курсив (italic), цвят: светъл сиво-син
(изм., v.xхх) (доп., v.xхх) (v.~xxx-...) | изменения/допълнения; нови/отпаднали текстове, абзаци, раздели от съответните цитирани версии спрямо последната редакция
*, **, ... | Забележки, бележки, пояснения и др. под. към раздел/абзац/термин и пр.
- вж. по-горе . | Препратка (линк) към раздел, друг източник, интернет-страница/адрес и др.под.
 | Настройки (settings), технически данни и/или спецификации, възможности и/или опции, които зависят от определени настройки, инсталиран външен софтуер/ъпдейти и др. под. действия.
 | Информационно съдържание, основни и/или допълнителни възможности...
 | Теория, дефиниции (определения), термини/терминология
 | детайли/разглеждане (в подробности)
 | Регионална информация (Важно: посочват се особености в условията на България)
 | Клавиатура / действия с клавиатура, клавиши, клавишни съчетания
 | Мишка / действия с мишка, бутони на мишката
 | Гледане /
 | "чекбокс" (checkbox) - опции с двузначна функция ("да" - при поставена отметка [image] , респ. "не" при празна клетка)
 | потвърждение (положителен отговор)
 | отказ (отрицателен отговор), забрана...
 | опции за избор на една от няколко възможности, обикновено изброени в съответна функционално обособена група (област) за настройки
 | опции за избор на една от няколко възможности от "падащо" меню в същия диалогов прозорец
 | опция в отделен (команден) ред от контекстно меню (или от отделен/допълнителен) диалогов прозорец
 | фиксирани величини (команди, опции), които се избират с "превъртане" във възходящ или низходящ ред (в мини-прозорец срещу съответната опция)
 | линейна скала (плъзгач/потенциометър)
 | вертикален регулатор (плъзгач/потенциометър)
 | настройки, свойства (properties), конфигурация (меню за~),...
 | допълнителни настройки...
 | прозорец (диалогов~, видео~)
 | подпрозорец/подпрозорци
 | browser / file manager / folder-subfolder
 | съхраняване/запис
 | Window$ (no comment)
§ , «», +/- | разделители; символи-подсказки и др. ...

При превода/редакцията са използвани вградени Windows-шрифтове: Arial, Wingdings, Symbol, които трябва да са инсталирани на потребителските машини за коректно визуализиране на форматираните и редактирани текстове в българските HELP-файлове.


Topic: Речник

List TV

Речник

Руско-български терминологичен речник

правка - редактиране, поправки, корекции

занес~ены; ~ти - внесени, добавени; ~да се внесат, добавят

напоминание~тель - напомняне (remind~er), аларма (...нещо като будилник).

...


Topic: Системна информация

List TV

Системна информация

Системна информация

Created with DrExplain

< Previous page Next page >
Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията!
© ListTV; Beholder-Europe.com


Topic: За контакти / Полезни връзки

List TV
< Previous page

За контакти / Полезни връзки

Регионална информация:

Автор и редактор на българския превод - Help и редактиран ресурсен файл *:

  • Официален сайт:

    http://www.beholder-europe.com

    http://www.beholder-europe.eu (if aviable)

    Е-mails:

    Int'l Beholder TV tuners requests: beholder.europe@gmai.com

    BG Beholder TV tuners requests: beholder.bg@gmai.com

    General Мanager (Direct): thebest@mail.bg

    Head Office & Trade dept.: megamarket@mail.bg

    Customs & Logistics dept.: bgcustoms@mail.bg

  • On-line contacts:

    Skype:simply_thebest

    QIP/ICQ: thebest (116449009)

  • Live conversation (GMT+2,0):

    Phone: + 359 2 4174080

    Fax: + 359 2 9741043

    Mob.: + 359 88 88 17639

*вж. също пояснителни бележки по превод и редактиране на български език

и полезни връзки :

  • «Лого» - материал с информация за телевизионни канали в България (логотипи, честоти, покритие, програми и пр.); вж. също

  • Набор материали за ТВ тунери -

    «Избор на ТВ тунер...»;

    «Борба с реклами...»;

    «BeholdTV_BGReview»; «Инсталиране на драйвери и софтуер...»;

    «Плъгини за BeholdTV» - «Logo Detector», «Logo Killer», «Logo Extractor» и под. - материали за премахване на реклами, вграждане на собствено лого и пр.

    «Универсално дистанционно управление на компютър» - «Perehvat»;

    « FLY 2000 TV » - пълно описание и интерфейс на български език;

  • ...to be continued...

...С пожелание информацията да е била полезна - до нови срещи!!!

Created with DrExplain

< Previous page